Convert XLS to CSV in Excel


T

Tony Liu

Hi,

When I convert Excel file from xls format to csv format, all Chinese
characters cannot display correctly. Why? How to solve it?

Computer Environment:
- Windows 2000 Pro (English, Default Locale: Trad. Chi.)
- Office 2000 (English)

Tony
 
Ad

Advertisements

R

rk_idiom

I haven't seen a better way to do this:

IN OFFICE 2000
1. Open Excel file.
2. Save the file as Unicode Text File xxx.txt.
3. Open the xxx.txt file in the Notepad.
4. Replace tab characters with comma (,) character. You can cut an
paste tab char into Replace box.
5. Save the file as UTF-8 xxx.csv file.
6. Open the xxx.csv file in an editor which does not understand
Unicode (VIM or Emacs will do). Take out first 3 bytes of the fil
(these are BOM chars looking like this: ).
7. Save the file

IN OFFICE XP
Office XP has a way to save the CSV file as UTF-8 directly from Excel
Do this and then do steps 6-7 above.

Regards,
Riz
 
Ad

Advertisements

Joined
Dec 31, 2010
Messages
1
Reaction score
0
In my experience Excel 2007 still is completely useless für csv export. I have a big table that has to be exported to csv. I need csv to load the data into my Web Application. The Web App uses MySQL.
Excel fails exporting the table correctly. It destroys my MySQL table when I import the excel generated csv.

OpenOffice Calc works perfect and it is free! You just have to go to File > Save as > Then choose Text CSV - in this dialog you can also check "filter settings". Then another dialog appears after you clicked on save - there you can choose your preferred character set like UTF8 or whatever, you can also choose the separator like , or ; whatever.

I also like OpenOffices PDF Export its superb! It's picture format and text positioning is also better than in word 2007.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top