com1 not working



My serial port, com1,(DB9) doesn`t seem to work anymore. Computer is a Dell
laptop. I use the serial port to communicate with a MicroChip programmer and
also hyperterminal. I am an electronics hobbyist and use hyperterminal to
setup a few things in an embedded web server in my home. My programmer just
gives message "can`t connect to com1"
Hyperterminal gives message "Another program is using the selected telphony
device. Try again after the other program completes."....How to find what
this "other"device is?
Here`s what happened to make it stop working.
I installed a device(home automation wireless device) called an "X10
It`s just a 1 inch square device with db9 connectors on each end. It`s
supposed to be "transparent" to other devices. I installed the drivers but
never really tried to use it. I removed the hardware one day to plug my
programmer in and got the message described above. I have uninstalled the X10
drivers, but still nothing works.
I tried uninstalling the com1 port under device manager. After uninstalling
i get message saying i must restart computer. So i do, and look under device
manager and com1 still is installed !
At this point i don`t know what is wrong...hardware is actually broken or
driver is corrupt? Not even sure if i`m in right forum !
How to determine if hardware is "broken" ?
Thank you in advance for anyone who might have any ideas for me.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question