chkdsk on Vista


G

Guest

Every time I boot or re-boot Vista Ultimate, it runs chkdsk on my C-Drive.
This takes a considerable time - almost 1 hour. For some reasons my usb
keyboard is disabled in this process and I therefore cannot cancel it. After
chkdsk has run through 5 long stages Vista then re-boots and reports that
c-drive is free of errors and Vista loads up normally.

How can I prevent chkdsk from running by default on every boot?
 
Ad

Advertisements

R

Richard G. Harper

By determining why it's running and eliminating that problem. I'd suspect
either a failing hard drive or something that causes Vista to crash or shut
down improperly and run scandisk when it's restarted.

--
Richard G. Harper [MVP Shell/User] (e-mail address removed)
* NEW! Catch my blog ... http://msmvps.com/blogs/rgharper/
* PLEASE post all messages and replies in the newsgroups
* The Website - http://rgharper.mvps.org/
* HELP us help YOU ... http://www.dts-l.org/goodpost.htm
 
R

Rick Rogers

Hi Michael,

Something is causing the dirty bit to be set. Open an elevated command
prompt by typing CMD into the start/search box, then right click the entry
in the start menu and use 'run as administrator'. From the prompt, run
'chkntfs /d'. Then close the prompt and restart the system. As that command
resets the drive, it should not run autochk at this point. If it does, then
something you have installed is causing the dirty bit to be set and you need
to look into what is running in the background.

--
Best of Luck,

Rick Rogers, aka "Nutcase" - Microsoft MVP

Windows help - www.rickrogers.org
My thoughts http://rick-mvp.blogspot.com
 
G

Guest

Any idea how to make autochk run if it isn't running on startup? The dirty
bit is set, but vista won't run chkdsk on startup. I even tried running
chkntfs /D, and later edited the registry entry manually (according to
directions from a knowledge base article) but the thing still won't run
chkdsk unless I boot from the DVD into recovery console. This might be a
Dell issue. **This reply is a cross-post reply - - please see 'Scan Disk does
not run at startup' posted 5/7/2007 by 'Jeff'.

dutchscout
 
G

Guest

I have the same problem. I cannot get chkdsk to run, ever, at a command
(yes, yes, yes, from an elevated, administrator level) due to the disk being
"in use by another process", even from Safe Mode! When I ask (in these same
ways, except I didn't try to edit the registry) it to run chkdsk after a
reboot/restart, it won't do that either. Please help!

bob k.
 
Ad

Advertisements

G

Guest

Ahah!

Okay, I got the no-scan-on-startup problem fixed on my computer. Credit
definately goes to the blogger who posted on this topic. I'll add the link,
but know that the first 3/4 of the article includes some frustrated
profanity. In a nutshell the stupid autochk.exe file is corrupted somehow,
so all you do is replace it. This takes some work in Vista, but it worked
for me. My computer scanned! I believe this was the real problem because my
computer used to scan itself, but wouldn't after a while. There is a very
significant chance the problem came from a microsoft hotfix. I'll leave it
to them to figure out if that's what happened or which hotfix, etc... All I
care about is my computer scans itself without recovery console :) So here
are the steps to fix this problem in Vista... the only problem is you will
need a windows XP Install disk (I'll explain why...)

Go to C:\Windows\System32
Right click on Autochk.exe -> Properties
Click the Security tab, then click Advanced (button)
On the new window 'Advanced Security Settings for Autochk.exe' click the
'Owner' tab
Below the box labeled 'Change owner to:' click 'Edit...'
In the new window, under 'Change owner to:' select yourself (or the
Administrators group), then click OK
Close all property windows for autochk.exe, then go back to (right click)
Properties->Security
Click 'Edit...'
On the window 'Permissions for Autochk.exe' select the Administrators group,
then under 'Allow' click the 'Full Control' checkbox
Click OK and close the property windows
Ok...NOW you can rename autochk.exe to autochk_old.exe (that took a lot of
work!)

Now, I looked at Vista's installation DVD. All of the system files are
tucked nicely into 1 .wim file. This is a windows image file, and I'm not
sure how to pull the files out of it, so I just grabbed a handy XP
installation CD. The autochk.exe file is located at
(DriveLetter):\I386\AUTOCHK.EXE

Copy the AUTOCHK.EXE file from the XP installation disk to
C:\WINDOWS\SYSTEM32\AUTOCHK.EXE and you should be good to go!

I'll recontact Dell with this information, apparently other (non-Dell) users
are having this problem too

Oh, yeah the site where I found the solution:
"http://www.suehappycowboy.org/blog/?p=112" Thanks!

dutchscout

PS As a followup, I searched online for 'how to open a wim file' in order to
get the vista 'version' AUTOCHK.EXE from the install.wim file on the install
disk. The process seems a little complicated, but there is a toolkit from
Microsoft for it. I'm probably just going to stick with the XP version until
there is a hotfix for this problem. The Microsoft toolkit for .wim files is
called the Windows Automated Installation Kit (WAIK) and is mostly for system
administrators. If you want to, though give it a try and let me know how it
goes! You might want to read this first:
http://www.windowsitpro.com/Article/ArticleID/94616/94616.html
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top