changing the semicolon as separator in csv



hi all

when i save a worksheet to a .CSV Excel uses the semicolon ";" character
as the default separator

Where do I chnage the setting so that it uses a comma "," character?


Dave Peterson

In Windows XP, it's under the control panel|Regional options tab
then click customize and look for List separator on the Numbers tab.

Or you could rename your .csv file to .txt

And the specify the delimiter when you get the text import wizard.

Earl Kiosterud

If you're in the US, or another country that uses the comma normally for a separator, then
changing the Windows Regional setting will be good. If you're in a country that normally
uses the semicolon, then you might want to leave your regional settings to match your
country. In that case, try using the Text Write Program at

It writes a text file from a worksheet, leting you specify things like the field separator,
independent of Windows settings.
Earl Kiosterud

Note: Top-posting has been the norm here.
Some folks prefer bottom-posting.
But if you bottom-post to a reply that's
already top-posted, the thread gets messy.
When in Rome...

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question