Cannot run the FrontPage Server Extensions on this page



Hi, I keep getting this error when i try to use the form I uploaded onto my
web site
" Cannot run the FrontPage Server Extensions on this page". I made sure the
submit button is pointed to _private/form.txt and it was saved as allfile as
it spesifys on the microsoft web site and its still not working. Any ideas?
could the form.txt file under _private be wrong?


I think it's because the "_private" directory is not accessible to the
public. If you go to your site (online not local) and then add
/_private you'll most likely get a 404 error. That's where you can
upload stuff that you don't want accessible to others which is making
is inaccessible to your submit function. Try it in another directory
to see if it works before doing too much more work...


Yes, I have installed and reinstalled extentions several times with no
results. Do you think this problem is server side or client side.


Didnt see that option under properties of _private. is it under somthing
els? I have a demo of their web site on my computer im working with.


I'm running server 2003, i looked under the folder security and sharing but
didnt see that option. maybe im just blind, what tab is it under now?

Steve Easton

If you're running your own server:
( I am assuming the procedure is similar to IIS in XP Pro )

Control Panel > Administrative Tools > Internet Information Services.

Click the plus by the web name.
Right click the _private folder and select Properties.
In the _private folder dialog that opens, if it didn't default to the Directory tab, click
Under Local Path: check the checkbox for Write.
Click Apply.
Close the IIS panel.

Stop and restart IIS or reboot the machine.

( I prefer to reboot )

Steve Easton
Microsoft MVP FrontPage
FP Cleaner
Hit Me FP


How did you "made sure the submit button is pointed to _private/form.txt" ?
And what does this actually mean:
"it was saved as allfile " - it is not an expression I have heard before.

A link to the published page always helps to diagnose problems.

Andrew Murray

Is your form page an *.asp by any chance? It needs to be *.htm or *.html to
use the FP form processor

Funkadyleik Spynwhanker

One thing you can try, is changing the destination;

- make it go to email and not a file if it works look for permissions issues
on _private as others have said

- take out the confirmation page (use the default while troubleshooting)
some javascripts and stuff that might be on confirmation page can interfere
with form submission

- change the form.txt file to not be in the _private folder

Changing these things around may provide clues about what the issue is.

Thomas A. Rowe

You don't set the submit button to point to anything, if you want the FP Form Handler to process the

Thomas A. Rowe (Microsoft MVP - FrontPage)
If you feel your current issue is a results of installing
a Service Pack or security update, please contact
Microsoft Product Support Services:
If the problem can be shown to have been caused by a
security update, then there is usually no charge for the call.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question