Cannot install driver for Imaging Devices



I have problems installing drivers in the Device Manager-> Imaging Driver for
1) New Creative Live Pro Webcam (USB connection);
2) 2-year-old Canon power shot pro1 digntal camera (USB connection);
3) A 5-year-old Sony MiniDV Camcorder (i-Link IEEE 1394 connection).

I have a 3-year old computer with XP SP2 Version 2002 home addition.

I first found out the problem when I tried to install the new webcam a week
ago. I followed the suggested installation procedure. After that, when I
plugged the webcam in a USB port, the computer correctly recognized it as
"Creative Webcam Live! Pro" in the Device Manager-> Imaging Driver but had a
yellow exclaimination mark in front of the description. After clicking on the
item, it showed the following device status:

The drivers for this device are not installed. (Code 28)
To reinstall the drivers for this device, click Reinstall Driver.
(I checked the driver details, and it stated no driver files have been
loaded for this device)

I tried to re-installed the driver but everytime I did that, a window popped
up showing the system was trying to copy the drivers to its destination but
almost immediately the hardware update wizard popped up and showed that:

there was a problem installing this hardware
Creative Webcam Live! Pro
An error occurred during the installation of the device
The data is invalid

I originally thought it was related to the webcam driver so contacted the
Creative customer support and tried a few things they recommeded and it still
didn't work. It always had a same error message.

So I tried to see if it works on my Cannon camera (I never connected the
camera directly to the computer and always used card reader for the file
download). Surprisingly, after following the installation procedure, the same
error appeared even though I downloaded and used the updated driver for this
camera from the Cannon website (despite Cannon mentioning that such action is
not required for XP with this camera). The system did recognize the hardware
correctly though.

Then I tried my Sony camcorder (with i-Link) and the same problem occured. I
have not used the camcorder for a long time, but it used to work on my old
computer with Windows ME through an i-Link.

One more note, my canon LiDe 20 scanner (USB connection) does work ok with
my system. That is unfortunately the only device that is rezognized in the
Control Panel->Scanners and Cameras.

It sounds like something in my system is preventing the copying of the
drivers. I appreciate any help and feedback if you know what is the root
cause of this problem.

Thanks in advance.


Cari \(MS-MVP\)

#3 should not need any drivers. You should just connect camcorder to PC
with firewire/iLink/IEEE1394 cable and once the camcorder is turned on and
in VCR mode it should be recognized by the PC. Like printers, it will not
necessarily appear instantly in the Device Manager or Imaging Devices.
That's normal.

#2 the quickest solution with a camera is ALWAYS to use a card reader.


Hi Cari,

Thanks. I tried again but still didn't work. Since all 3 devices experience
similar problems (cannot install/find driver), I guess there might be
something corrputed/missing in the windows folders/registry, but I don't know



Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question