Cannot connect Vista to NAS using wireless router



Greetings all.

I have a Dell laptop running Vista personal home premium (as a preinstalled
OEM version). It connects to my home network through a wireless router
(TrendNet TEW-431BRP):
I need it to connect to my NAS (Maxtor Shared Storage II):
I also have a desktop computer running Windows XP SP2 which also connects to
the router through a wireless connection.

I have no antispyware, Windows firewall is off. All start up programs are

The laptop can connect to the internet and it can also share files with my
desktop computer running Windows XP SP2 both through the wireless router.
When I hardwire the laptop directly to the NAS with a cable everything works
like it should.

The XP machine has no problems connecting to the network drive using the
supplied software or by issuing the command \\MSS-03903F (which is the name
of the hardware) from the Run box in Vista. When I ping the NAS using its
fixed IP I also get a response.

When I try the same in Vista nothing happens. I get the error that no
network is found. When I ping the NAS, using its fixed IP address
( i get no response.

Apparantly there is something called DHCP BROADCAST flag, which is a feature
of Vista. I dont know if my router supports that, but it does not help to
follow the instructions given in Microsofts knowledge base concerning this

Maxtor has a fix that describes an issue about logging in, but it does not
apply to this situation I guess. Anyhow I tried the tweak with no success:
"Unable to login to a private share with a MSS+ drive when using Windows
Vista": Search for 3606 in their support section:

Maxtor support tells me that the router is to blame.
Trendnet support tells me to Google the problem
Windows support tells me to contact Dell
Dell support does no support on third party hardware :-(

So here I am, asking all you nice people for some help. Does anyone in here
know what to do here, what tweak to do, or should I just throw out that awful
Vista box and buy a Mac?

With the best regards,

Robert L. \(MS-MVP\)

It could be the NTLMv2 authentication issue. This search result may help,

Vista and LM Authentication LevelVista and LM authentication level Issues.
Access is denied when Vista accesses a FAT32 drive Solved: share between
Vista and Snap Server ...

Networking, Internet, Routing, VPN Troubleshooting on
How to Setup Windows, Network, VPN & Remote Access on

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question