Cannot Boot Windows 2000 after Erasing 2nd Harddisk with Linux


F

flahmeshess

I have 2 harddisk:
- master: Win2000
- slave: Linux

I had device problem with the 2nd harddisk (Linux). So I run Disk
Fitness Test from Hitachi. I cannot resolve the problem and Hitachi
recommended me to try to erase the disk and try again. So I ran DFT
to erase the disk.

After that, I cannot boot Win2000. When I boot, I get:

Searching for Boot Record from IDE-0. .OK
GRUB

What do I do ? Try installing Linux on the 2nd harddisk again ? Or
running some utilities to change the boot up ?

Thanks for any advice.
 
Ad

Advertisements

P

Pegasus

flahmeshess said:
I have 2 harddisk:
- master: Win2000
- slave: Linux

I had device problem with the 2nd harddisk (Linux). So I run Disk
Fitness Test from Hitachi. I cannot resolve the problem and Hitachi
recommended me to try to erase the disk and try again. So I ran DFT
to erase the disk.

After that, I cannot boot Win2000. When I boot, I get:

Searching for Boot Record from IDE-0. .OK
GRUB

What do I do ? Try installing Linux on the 2nd harddisk again ? Or
running some utilities to change the boot up ?

Thanks for any advice.

You need to replace the Grub Master Boot Record (MBR) with the
Windows MBR. There are a couple of ways of doing this:

- Boot the machine with a Win98 boot disk (www.bootdisk.com),
then type fdisk /mbr
- Boot the machine with your Win2000 CD, get into the Command
Console mode, then type fixmbr
 
T

Timothy Murphy

flahmeshess said:
I have 2 harddisk:
- master: Win2000
- slave: Linux

I had device problem with the 2nd harddisk (Linux). So I run Disk
Fitness Test from Hitachi. I cannot resolve the problem and Hitachi
recommended me to try to erase the disk and try again. So I ran DFT
to erase the disk.

After that, I cannot boot Win2000. When I boot, I get:

Searching for Boot Record from IDE-0. .OK
GRUB

What do I do ? Try installing Linux on the 2nd harddisk again ? Or
running some utilities to change the boot up ?

Presumably you have deleted the grub files
which would normally have been kept in /boot/grub/ on the Linux disk.

If you have a working Linux system you could create
a grub floppy to boot from -
or an isolinux floppy.
Or you could use knoppix to create such a floppy.

But if you are going to install Linux anyway on /dev/hdb
just go ahead, and grub should be re-installed,
giving you access to W2k.
 
A

Andy Fraser

In comp.os.linux.misc, flahmeshess uttered these immortal words:
I have 2 harddisk:
- master: Win2000
- slave: Linux

I had device problem with the 2nd harddisk (Linux). So I run Disk
Fitness Test from Hitachi. I cannot resolve the problem and Hitachi
recommended me to try to erase the disk and try again. So I ran DFT
to erase the disk.

After that, I cannot boot Win2000. When I boot, I get:

Searching for Boot Record from IDE-0. .OK
GRUB

GRUB installs some code in the Master Boot Record that loads the second
stage boot loader from a Linux partition to allow the system to boot.
Removing Linux like that has removed the second stage boot loader leaving
the system unbootable.
What do I do ? Try installing Linux on the 2nd harddisk again ? Or
running some utilities to change the boot up ?

Either reinstall Linux which will reinstall GRUB and make the system
bootable again or boot the win2k CD (if you have one) and use the recovery
console to reload the Windows MBR code. Either fixmbr, fixboot or something
like that should do that.
 
F

flahmeshess

Must it be Win98 ? I have a Dr DOS 7.x floppy handy. So I tried to
issue fdisk /mbr.

Still the same problem.

I boot again and went into the menu to check. I notice that it has an
option to rewrite MBR for the first disk but not the 2nd disk (which
is what I want).

I'm still stuck.

I really hope I don't have to reinstall Linux for the time being cause
the harddisk is defective and it will give problems if I write to it
(random problem). I need to RMA the harddisk but I don't want to wait
until I get a new harddisk to start using my PC again.
 
P

Pegasus

Let's get a few things about the boot sequence cleared up.
When you turn on your PC then the this sequence is followed,
in this order:
1. The BIOS boot program executes.
2. The BIOS program hands control to a small program in
the Master Boot Record (MBR) of the primary master
disk. This disk must be set to "active".
3. The MBR program passes control to the boot sector.
4. In the case of Win2000, the boot sector invokes ntdetect.com
and ntldr.

I now recommend that you walk before you run:
- Disconnect your second drive.
- Boot off a Win98 boot disk. A DRDOS7 disk may do but I have
never tried one.
- Execute this command: fdisk /mbr
- Reboot the machine

This will get rid of the Grub boot loader. It may or may not let
you boot into Win2000 - some additional steps may be required.
 
Ad

Advertisements

F

flahmeshess

Do I reload the MBR code into the Win2k Harddisk or the Linux Harddisk
(ie the erase HDD) ? Thanks.
 
P

Pegasus

Please read my detailed explanation. I posted it one hour before
you wrote this note.
 
F

flahmeshess

When I use Dr DOS 7.x, it gives me an option to "Re-write Master Boot
Record" but this option is available only for the Win2000 HDD and not
the Linux HDD.

Would it help if I select this option or it would damage my Win2000 ?
Thanks.
 
P

Pegasus

As I said, I have no experience with DRDOS. I recommend you
download the boot disk for which I gave you the link.
 
A

Andy Fraser

In comp.os.linux.misc, flahmeshess uttered these immortal words:
Do I reload the MBR code into the Win2k Harddisk or the Linux Harddisk
(ie the erase HDD) ? Thanks.

The MBR on /dev/hda. Windows will only do that IIRC and most Linux distros
know where to put the first stage bootloader when you select "MBR" or
equivalent option.

Please don't top post.
 
Ad

Advertisements

F

flahmeshess

I manage to boot up from Win2k. I remove the slave harddisk for RMA
and now, I cannot boot up again... it says

GRUB Hard Disk Error.

How do I remove the dependency on the slave hard disk ? Thanks.
 
F

flahmeshess

I use Recovery Console to run fixmbr.

It says:

Is this because I have Linux on the other hard disk ? Or is my boot
record all messed up ?
I have a issue here. If I take my Slave HDD to RMA, it will take a
few weeks. And I would not be able to use my computer for that period.
I can cannot backup my data on my Master HDD cause I use the Slave as
Backup.

If I proceed and I cannot access the partition, the I've lost all my
data.

What should I do ?

Thanks.
 
Ad

Advertisements

P

Pegasus

The message you see is a standard message issued by fixmbr.
You can go ahead safely. There are only two know cases
where replacing the MBR causes a problem:

a) If you use a proprietary disk storage scheme, e.g. OnTrack;
b) If your machine has been infected with a virus that resides
in the MBR.

Since you're apprehensive about restoring the MBR to its
original value, I suggest a staged approach.

1. Boot the machine with a Win2000 boot disk, to see if this
fixes the problem:
- Format a floppy disk on some Win2000 PC.
Don't do it on a Win9x PC - it won't work.
- Copy these files from the \i386 folder of your Win2000 CD
to A:\
ntldr
ntdetect.com
- Copy c:\boot.ini to A:\, or create a:\boot.ini with these lines
[Boot Loader]
Timeout=3
Default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[Operating Systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000
Professional" /fastdetect

If this works then you know that a standard MBR will work.

2. Save the MBR before restoring it. Disksave.exe from the Win2000
Resource Kit will do it. You can also scan Google for similar programs
in the public domain.

3. If you have sufficient empty space on some partition then you can
take a snapshot of drive C:, using an imaging tool such as Ghost, DriveImage
or TrueImage. If things go wrong then you can restore this image.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top