Boot problems


D

Daniel

Hi

I have recently bought an Asus CM 6730 PC with a 2TB hard drive.

The drive was supplied with four partitions, 1) 100 MB System reserved ( I
believe a boot partition). 2 a 19GB unnamed, I guess a recovery partition,
3) A 270 GB OS Partition
and 4) A 1.4 TB Data Partition.

When the PC was supplied it had W7 installed on the A 270 GB OS Partition,
but I like the OS installed on the biggest partition as I have a lot
of big graphics programs and files that work better for me if they are on
the same partition, so I formatted drive 3 and 4 and installed W8
on the 4 (Data) partition, now the C: drive.

It works well most of the time but about every three days when I start up
the PC does not boot and I get a message "BOOTMGR is missing"

I have tried running Fixboot from the CMD Prompt on the W8 Install disk
repair my PC option, but the C: drive is not found, but when I go to C: it
is found and I can run
chkdsk /f /r after rebooting and the PC restarts okay, sometimes running the
chkdsk, sometimes not.

Can anyone let me know what may be happening, I suspect the issue may lie
with conflicting boot sectors because I installed W8 without any knowledge
of the Boot partition.

Any advice on this issue is appreciated.

Regards

Daniel
 
Ad

Advertisements

D

Darklight

Daniel said:
Hi

I have recently bought an Asus CM 6730 PC with a 2TB hard drive.

The drive was supplied with four partitions, 1) 100 MB System reserved ( I
believe a boot partition). 2 a 19GB unnamed, I guess a recovery partition,
3) A 270 GB OS Partition
and 4) A 1.4 TB Data Partition.

When the PC was supplied it had W7 installed on the A 270 GB OS
Partition, but I like the OS installed on the biggest partition as I have
a lot of big graphics programs and files that work better for me if they
are on the same partition, so I formatted drive 3 and 4 and installed W8
on the 4 (Data) partition, now the C: drive.

It works well most of the time but about every three days when I start up
the PC does not boot and I get a message "BOOTMGR is missing"

I have tried running Fixboot from the CMD Prompt on the W8 Install disk
repair my PC option, but the C: drive is not found, but when I go to C: it
is found and I can run
chkdsk /f /r after rebooting and the PC restarts okay, sometimes running
the chkdsk, sometimes not.

Can anyone let me know what may be happening, I suspect the issue may lie
with conflicting boot sectors because I installed W8 without any
knowledge of the Boot partition.

Any advice on this issue is appreciated.

Regards

Daniel

best thing to do is delete all partions and reformate the drive.

question the 19 GB partition did windows 8 recognise it's formate?

If win8 did not recognise it's file formate that partition is more than
likely linux

question what did you do with the 19GB partition?
 
P

Paul

Daniel said:
Hi

I have recently bought an Asus CM 6730 PC with a 2TB hard drive.

The drive was supplied with four partitions, 1) 100 MB System reserved (
I believe a boot partition). 2 a 19GB unnamed, I guess a recovery
partition, 3) A 270 GB OS Partition
and 4) A 1.4 TB Data Partition.

When the PC was supplied it had W7 installed on the A 270 GB OS
Partition, but I like the OS installed on the biggest partition as I
have a lot
of big graphics programs and files that work better for me if they are
on the same partition, so I formatted drive 3 and 4 and installed W8
on the 4 (Data) partition, now the C: drive.

It works well most of the time but about every three days when I start
up the PC does not boot and I get a message "BOOTMGR is missing"

I have tried running Fixboot from the CMD Prompt on the W8 Install disk
repair my PC option, but the C: drive is not found, but when I go to C:
it is found and I can run
chkdsk /f /r after rebooting and the PC restarts okay, sometimes running
the chkdsk, sometimes not.

Can anyone let me know what may be happening, I suspect the issue may
lie with conflicting boot sectors because I installed W8 without any
knowledge
of the Boot partition.

Any advice on this issue is appreciated.

Regards

Daniel

I can't tell you whether this will help, but I suspect Windows 8 sometimes
has a problem with "spinning down" drives when they're idle. Something
gets corrupted, and is not being handled properly.

To stop that on the Windows 8 preview, I went to the Power Options control
panel, and disabled disk spin down. If you set the disk spin down time to
zero minutes, the display will change to "Never", indicating the function
is effectively disabled. After I did that, I no longer had problems with
my disks. The idea is to keep the disks spinning, so they don't change
power states. Changing power states would not be a problem, if all levels
of caching were being flushed properly.

Another command you can do, is "powercfg -h off", which disables Hibernate,
but that one is mainly so you have more complete control over booting, from
the BIOS. If you don't disable the kernel hibernate, there's a tendency for
the computer to ignore attempts to use the popup boot menu.

Those are the two things I did to my new Win8 install, as discovered
by testing the preview versions.

Paul
 
D

Daniel

"Darklight" wrote in message

best thing to do is delete all partions and reformate the drive.

question the 19 GB partition did windows 8 recognise it's formate?

If win8 did not recognise it's file formate that partition is more than
likely linux

question what did you do with the 19GB partition?

Hi

all four partitions are recognised in Disk manager but the
"1) 100 MB System reserved ( I
believe a boot partition). and 2 a 19GB unnamed,"
are not seen in Explorer.

In Disk Manager 1 is NTFS the 2 file system is not stated but Casper 7
boot disk (a brilliant cloning/backup software) shows it a FAT32.

BTW if I boot up with my W8 disk in the DVD drive the PC boots okay,
I only just found this out.

I did nothing with the 19GB partition but I believe it is used to make the
recovery disk
when you first start the PC.

Appreciate your input

Regards

Daniel
 
D

Daniel

"Paul" wrote in message

I can't tell you whether this will help, but I suspect Windows 8 sometimes
has a problem with "spinning down" drives when they're idle. Something
gets corrupted, and is not being handled properly.

To stop that on the Windows 8 preview, I went to the Power Options control
panel, and disabled disk spin down. If you set the disk spin down time to
zero minutes, the display will change to "Never", indicating the function
is effectively disabled. After I did that, I no longer had problems with
my disks. The idea is to keep the disks spinning, so they don't change
power states. Changing power states would not be a problem, if all levels
of caching were being flushed properly.

Another command you can do, is "powercfg -h off", which disables Hibernate,
but that one is mainly so you have more complete control over booting, from
the BIOS. If you don't disable the kernel hibernate, there's a tendency for
the computer to ignore attempts to use the popup boot menu.

Those are the two things I did to my new Win8 install, as discovered
by testing the preview versions.

Paul

Hi

is it possible that it is always the BOOTMGR that is corrupted, it is true
that
when the problem happens Windows want to scan and fix disk errors?

Do I run "powercfg -h off" form CMD in Windows or from a DOS CMD from
a Bootdisk?

Thanks and regards

Daniel
 
D

Daniel

I can't tell you whether this will help, but I suspect Windows 8 sometimes
has a problem with "spinning down" drives when they're idle. Something
gets corrupted, and is not being handled properly.

To stop that on the Windows 8 preview, I went to the Power Options control
panel, and disabled disk spin down. If you set the disk spin down time to
zero minutes, the display will change to "Never", indicating the function
is effectively disabled. After I did that, I no longer had problems with
my disks. The idea is to keep the disks spinning, so they don't change
power states. Changing power states would not be a problem, if all levels
of caching were being flushed properly.

Another command you can do, is "powercfg -h off", which disables Hibernate,
but that one is mainly so you have more complete control over booting, from
the BIOS. If you don't disable the kernel hibernate, there's a tendency for
the computer to ignore attempts to use the popup boot menu.

Those are the two things I did to my new Win8 install, as discovered
by testing the preview versions.

Paul

Hi have change the disk spin down to Never but I still have the problem.

New info is that the PC boots okay if the W8 install disk is in the DVD
drive
but the BOOTMGR problem now happens all the time if the Disk is not in
the drive?

Regards

Daniel
 
Ad

Advertisements

P

Paul

Daniel said:
Hi have change the disk spin down to Never but I still have the problem.

New info is that the PC boots okay if the W8 install disk is in the DVD
drive
but the BOOTMGR problem now happens all the time if the Disk is not in
the drive?

Regards

Daniel

So whatever the repair thinks it is doing, is not working.

On Windows 7, there were two partitions. A 100MB "System Reserved"
partition, contained some boot stuff. The main C: held the
rest of the OS.

On Windows 8, at least here, it installed in a single partition.
I don't know if it was supposed to do that or not.

Since Windows 8 is on a separate disk, and connected to my
motherboard right now, I can see a single partition for the
OS, and it is marked "Healthy (Active)" in Disk Management.
That means the boot flag is active on that partition.

In terms of tools to work on the BCD, you have things
like the free EasyBCD...

http://en.wikipedia.org/wiki/EasyBCD

or the built-in command line "bcdedit".

You run the command line tools from an MSDOS prompt.
In Windows 8, when you are looking at the tile view,
you type in "cmd" without the quotes, and that should
match the "cmd.exe" application. If you want to run
that elevated, you'd try right-clicking on whatever the
search returns, and select "Run As Administrator". If
you want MSDOS to run as a regular user, then don't
bother with the Run As Administrator step. The traditional
MSDOS prompt should show up when you run "cmd.exe".

(Picture of Run As Administrator...)

http://www.file-extensions.org/imgs/articles/2/164/windows-8-metro-cmd-run-as-administrator.png

You can run the "powercfg -h off" there.
And if you didn't like the result, run "powercfg -h on" later.

*******

There is a tool "bootrec" here, which can be used to attempt
to repair the BCD. I presume such a repair, would scan the
computer for all Windows OSes, and try and build a menu so
they're all available.

http://support.microsoft.com/kb/927392#method1

There is also a bcdboot tool. It looks like, in principle,
you might even be able to change a single partition install,
into a two partition install with this. But using the
"bcdboot C:\Windows" form of the command is likely
enough to repair a single partition installation.

http://technet.microsoft.com/en-us/library/dd744347

Some of the tools should be in the system, but occasionally
you'll run into something that's only available in the
recovery console. But cross that bridge when you get there.
I haven't needed to repair anything on Win8 yet.

Paul
 
D

Daniel

"Daniel" wrote in message




I can't tell you whether this will help, but I suspect Windows 8 sometimes
has a problem with "spinning down" drives when they're idle. Something
gets corrupted, and is not being handled properly.

To stop that on the Windows 8 preview, I went to the Power Options control
panel, and disabled disk spin down. If you set the disk spin down time to
zero minutes, the display will change to "Never", indicating the function
is effectively disabled. After I did that, I no longer had problems with
my disks. The idea is to keep the disks spinning, so they don't change
power states. Changing power states would not be a problem, if all levels
of caching were being flushed properly.

Another command you can do, is "powercfg -h off", which disables Hibernate,
but that one is mainly so you have more complete control over booting, from
the BIOS. If you don't disable the kernel hibernate, there's a tendency for
the computer to ignore attempts to use the popup boot menu.

Those are the two things I did to my new Win8 install, as discovered
by testing the preview versions.

Paul

Hi have change the disk spin down to Never but I still have the problem.

New info is that the PC boots okay if the W8 install disk is in the DVD
drive
but the BOOTMGR problem now happens all the time if the Disk is not in
the drive?

Regards

Daniel

Hi

I fixed the MBR and all seems to be okay, having also changed the spin down
time to never
hopefully the BOOTMGR problem will not return.

Thanks again for your help,
regards

Daniel
 
D

Darklight

Daniel said:
"Darklight" wrote in message

best thing to do is delete all partions and reformate the drive.

question the 19 GB partition did windows 8 recognise it's formate?

If win8 did not recognise it's file formate that partition is more than
likely linux

question what did you do with the 19GB partition?

Hi

all four partitions are recognised in Disk manager but the
"1) 100 MB System reserved ( I
believe a boot partition). and 2 a 19GB unnamed,"
are not seen in Explorer.

In Disk Manager 1 is NTFS the 2 file system is not stated but Casper 7
boot disk (a brilliant cloning/backup software) shows it a FAT32.

BTW if I boot up with my W8 disk in the DVD drive the PC boots okay,
I only just found this out.

I did nothing with the 19GB partition but I believe it is used to make the
recovery disk
when you first start the PC.

Appreciate your input

Regards

Daniel

do you have a spare hdd lying around. If so disconnect the 2 tb drive
connect the spare drive wipe clean and install win8 on that. Then you will
know what to do with the 2 tb drive
 
Ad

Advertisements

D

Daniel

"Darklight" wrote in message
"Darklight" wrote in message

best thing to do is delete all partions and reformate the drive.

question the 19 GB partition did windows 8 recognise it's formate?

If win8 did not recognise it's file formate that partition is more than
likely linux

question what did you do with the 19GB partition?

Hi

all four partitions are recognised in Disk manager but the
"1) 100 MB System reserved ( I
believe a boot partition). and 2 a 19GB unnamed,"
are not seen in Explorer.

In Disk Manager 1 is NTFS the 2 file system is not stated but Casper 7
boot disk (a brilliant cloning/backup software) shows it a FAT32.

BTW if I boot up with my W8 disk in the DVD drive the PC boots okay,
I only just found this out.

I did nothing with the 19GB partition but I believe it is used to make the
recovery disk
when you first start the PC.

Appreciate your input

Regards

Daniel

do you have a spare hdd lying around. If so disconnect the 2 tb drive
connect the spare drive wipe clean and install win8 on that. Then you will
know what to do with the 2 tb drive

All fixed, thanks for your input.

Cheers

Daniel
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top