Automatically detect settings of LAN stopped working



I am using IE6 on XP with all the latest updates.

Under the LAN settings dialog box, I have "Automatically detect settings"
and "Use automatic configuration script" both checked. The proxy
configuration script I point to is on my company's intranet (which I access
via a VPN).

This has been working great for years - when I am on the VPN, IE detects and
uses the proxy, and when I am not on the VPN, IE detects that it cannot reach
the proxy and accesses internet websites directly. I believe this is how
"Automatically detect settings" is supposed to work.

Recently, I set up IE to use Outlook Express as the default news reader.
And in some way, this has screwed up the automatic detection mechanism. Now,
with the exact same LAN settings, it ALWAYS tries to use the proxy, and
eventually times out when I am not on the VPN (regardless that "Automatically
detect settings" is checked). So basically, in order to make IE work, I have
to manually go into IE LAN settings and check or uncheck "Use automatic
configuration script" depending on whether or not I am on the VPN. This is

I swear, the only thing I did was set Express as the news reader and I have
made no other configuration changes. Does anyone have suggestions on what I
might try to fix this problem? (other than Windows reinstall or upgrading to
IE7 !!)



I am having the same problem with IE7, it started 4/11/2007. We need
to uncheck "Automatically Detect Settings" to access internal stuff,
and check it to access external stuff through the corporate proxy
server. It may not be related to Outlook Express. We did nothing
with Express.


I didn't really get any help on this at all from any newsgroup/support
article, but after playing around with it for a while, I found out that if I
remove the proxy config file name (but leave the server), it seems to work

So it used to say "" and now it just reads

I don't really know why it broke, but I had the exact same thing occur on 2
different machines at different times - so it's not just a fluke, and I
believe it was related more to something specific with the machine than a
change on the proxy.

I'm still pretty sure it had something to do with setting up Outlook Express
for my newsgroup reader.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question