Auto Time Sync not working

Discussion in 'Windows XP Configuration' started by Ron Boetger, May 1, 2007.

  1. Ron Boetger

    Ron Boetger Guest

    We have a workstation that cannot Auto Synchronize with the Internet
    time server
    We get "An error occurred getting the status of the last
    synchronization. The RPC server is unavailable."

    Any Ideas how to fix this?
    Thanks
     
    Ron Boetger, May 1, 2007
    #1
    1. Advertisements

  2. Ron Boetger

    Wesley Vogel Guest

    Internet time server

    A recent Windows Update (Daylight Saving Time maybe) has messed this up.

    Try this.

    Double click your clock on the taskbar.
    Date and Time Properties should open.
    Click on the Internet Time Tab.
    In the box next to Server, type or paste: time-b.nist.gov
    Click the Apply button.
    Then click the Update Now button and wait a while.
    Close the Date and Time Properties when you see: The time has been
    successfully...


    Server...
    [[Enables you to select the Internet time server with which you want to
    synchronize your computer clock. Click one of the options or type in an
    address.
    The time server time.windows.com is operated by Microsoft, and time.nist.gov
    is operated by the U.S. government. Other time servers provided by your
    computer’s manufacturer might also be listed. You can type the name of a
    time server if you want to use one that is not listed. Only time servers
    that use the Simple Network Time Protocol (SNTP) will work. Inserting an
    Internet address that uses the Hypertext Transfer Protocol (HTTP) will not
    work.]]

    Update Now button...
    [[Click to synchronize your computer clock with the selected Internet Time
    Server. You must be connected to the Internet, and the Automatically
    synchronize with an Internet time server check box must be selected.
    If synchronization fails, a message will display below explaining the
    reason. Most corporate firewalls will block time synchronization, as will
    some personal firewalls. If the network is too busy or not available for
    some reason, try again later.]]
    ---------

    If that doesn't help...

    An error occurred getting the status of the last synchronization. The RPC
    Server is unavailable.

    Make sure that the Windows Time service is running.

    Open Services...
    Start | Run | Type: services.msc | Click OK |
    Scroll down to and double click Windows Time |
    If the Startup type is Disabled, set it to Automatic or Manual |
    Start the service by clicking the Start button | When the service starts,
    close Services

    Try to update the time again.

    Sometimes the server is just busy, try again later.

    To restore the Windows Time Service if it has been broken. Open a command
    prompt...
    Start | Run | Type: cmd | Click OK |

    Type: net stop W32Time hit your Enter key.

    Type: w32tm /unregister hit your Enter key.

    Type: w32tm /register hit your Enter key.

    Type: net start W32Time hit your Enter key.

    Type: sc query W32Time hit your Enter key.

    It will look something like this...

    ------------------
    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\>net stop W32Time
    The Windows Time service is not started.

    More help is available by typing NET HELPMSG 3521.

    C:\>NET HELPMSG 3521

    The *** service is not started.

    C:\>w32tm /unregister
    The following error occurred: Access is denied. (0x80070005)

    C:\>w32tm /register
    W32Time successfully registered.

    C:\>net start W32Time
    The Windows Time service is starting.
    The Windows Time service was started successfully.

    C:\>sc query W32Time

    SERVICE_NAME: W32Time
    TYPE : 20 WIN32_SHARE_PROCESS
    STATE : 4 RUNNING
    (STOPPABLE,NOT_PAUSABLE,ACCEPTS_SHUTDOWN)
    WIN32_EXIT_CODE : 0 (0x0)
    SERVICE_EXIT_CODE : 0 (0x0)
    CHECKPOINT : 0x0
    WAIT_HINT : 0x0

    C:\>
    ------------------

    If you still are having problems. Maybe run the unregister command, reboot,
    run the register command and reboot.

    Type in a command prompt:

    w32tm /unregister

    Hit Enter. Close whatever you need to close and reboot.

    Type in a command prompt:

    w32tm /register

    Hit Enter. See if Windows Time is in Services, if not reboot and look
    again.

    Explanation.

    w32tm /register
    Register to run as a service and add default configuration to the registry.

    w32tm /unregister
    Unregister service and remove all configuration information from the
    registry.

    For help, type: w32tm /?

    Also, paste the following line into Start | Run and click OK...

    hh ntcmds.chm::/time_w32tm.htm

    --
    Hope this helps. Let us know.

    Wes
    MS-MVP Windows Shell/User

    In
     
    Wesley Vogel, May 3, 2007
    #2
    1. Advertisements

  3. Ron Boetger

    Ron Boetger Guest

    Many thanks for the help! Boy I had to do all of the things listed.
    Then the computer sync 'd with the time server BUT when I hit the
    update button for a second time the update failed.

    Then I tried on my laptop and I received the same message.

    An error occurred while Windows was synchronizing......

    Thanks

    Ron


     
    Ron Boetger, May 6, 2007
    #3
  4. Ron Boetger

    buzzlight Guest

    Thankyou worked for me!!
     
    buzzlight, May 7, 2007
    #4
  5. Ron Boetger

    Ron Boetger Guest

    I am strating to find this all over the place!!! No ones clocks are
    correct.

    Can we remove the DST update? I can't do this on a hundred computers!

    Thanks
     
    Ron Boetger, May 18, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.