Auto Logon Shift key override does not work


G

Guest

I am trying to set up my machine to automatically log on to a user account.
This works fine, but sometimes I need to log on to a different account for
admin tasks etc. The problem I am getting is that holding the shift key
during boot up does not bring up the windows logon screen. Windows
automatically boots to the account I set up to automatically log on. I am
using Windows XP SP2 and my auto logon registry settings are as follows,

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"DefaultUserName"="testUser"
"DefaultDomainName"=""
"DefaultPassword"="Password"
"AltDefaultUserName"=""
"AltDefaultDomainName"=""
"AltDefaultPassword"=""
"AutoAdminLogon"="1"
"ForceAutoLogon"="0"

Any ideas?
 
Ad

Advertisements

N

Nightowl

stu9000 said:
I am trying to set up my machine to automatically log on to a user account.
This works fine, but sometimes I need to log on to a different account for
admin tasks etc. The problem I am getting is that holding the shift key
during boot up does not bring up the windows logon screen. Windows
automatically boots to the account I set up to automatically log on. I am
using Windows XP SP2 and my auto logon registry settings are as follows,

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"DefaultUserName"="testUser"
"DefaultDomainName"=""
"DefaultPassword"="Password"
"AltDefaultUserName"=""
"AltDefaultDomainName"=""
"AltDefaultPassword"=""
"AutoAdminLogon"="1"
"ForceAutoLogon"="0"

Any ideas?

Hi stu

Your settings are a little different from mine -- I'm guessing you
followed the procedure in the MS Knowledge Base article 315231, or
perhaps you used TweakUI? According to that KB article, you need to set
ForceAutoLogon to 1 -- try that and see if it works. You might also be
pressing Shift a little too early or too late -- you could try tapping
it repeatedly instead, starting as soon as the system starts to boot.

I set auto logon using Start | Run | control userpasswords2 and don't
have the ForceAutoLogon entry or the DefaultPassword entry with my
password showing. Maybe you might prefer to undo the changes you made
and then try setting up auto logon this way?

Start | Run, type: control userpasswords2 <ok>

Click to highlight the name of the user you want to automatically log
on.
Uncheck the "Users must enter a username and password. . ." box.
Click Apply.
In the Automatically Log On window, your username should be showing.
Type your logon password in both boxes.
Click OK, then OK again to close both windows.

Hope this helps -- let us know how it goes :)
 
N

Nightowl

Nightowl said:
Your settings are a little different from mine -- I'm guessing you
followed the procedure in the MS Knowledge Base article 315231, or
perhaps you used TweakUI? According to that KB article, you need to set
ForceAutoLogon to 1 -- try that and see if it works.

Hi again stu -- I just came across this article which explains why
ForceAutoLogon=1 might be rather undesirable :) :
http://blogs.msdn.com/oldnewthing/archive/2006/03/06/544496.aspx

If you have other people using the machine, you might want to try the
control userpasswords2 method, that doesn't seem to have the same
drawback. The replies to the article do imply that Shift still works
with ForceAutoLogon, though :)
 
G

Guest

Thanks for the fast reply.

After trying every single combination of registry settings we could think of
and still getting problems with the shift key override we tried tapping the
shift key like you suggested. Turns out that the timing is very important. It
appears that you have to wait until the mouse cursor appears, then press
shift and the override works fine.

Thanks for the help.

Stu
 
Ad

Advertisements

N

Nightowl

stu9000 said:
After trying every single combination of registry settings we could think of
and still getting problems with the shift key override we tried tapping the
shift key like you suggested. Turns out that the timing is very important. It
appears that you have to wait until the mouse cursor appears, then press
shift and the override works fine.

Thanks for the help.

Great, glad you got it sorted out :)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top