ATI Radeon 9800 and AMD Opteron 180



I have a MSI Neo2 Platinum (nVidia nforce 3 ultra chipset). One of the last
AMD 939 AGP boards made. I have an ATI Radeon 9800 Pro. With Vista 32 and
Vista 64, the ATI drivers, and even Microsoft's drivers, worked just fine -
when I had an AMD 64 3000+ CPU in it.

I just put in a shiny new AMD Opteron 180, and all the sudden the drivers
are failing, both in 64 and 32. Installing the newest drivers didn't help.
Reinstalling Vista didn't help. The error I get in Device Manager is:

Windows was able to successfully install device driver software, but the
driver software encountered a problem when it tried to run. The problem code
is 43.

Problem signature:
Problem Event Name: PnPDeviceProblemCode
Architecture: x86
Hardware Id: PCI\VEN_1002&DEV_4E48&SUBSYS_00021002&REV_00
Setup class GUID: {4d36e968-e325-11ce-bfc1-08002be10318}
PnP problem code: 0000002B
Driver name: atikmdag.sys
Driver version:
Driver date: 01-19-2007
OS Version: 6.0.6000.
Locale ID: 1033

Suggestions? Everything works perfectly in XP.




When installing new video card drivers, you always get the best results by
first removing the prior drivers. The Add/Remove Programs app in Control
Panel should have the ability to uninstall all the prior drivers. Also,
remove all ATI folders in C:\ATI. That's the location to where the ATI
drivers go when you unzip them. That's where the ATI setup.exe is located.

After uninstalling all graphics drivers, reboot the computer and, after the
BIOS POST but before windows appears, press F8 to see a screen containing
various boot options. One of the options will be to boot in Standard VGA
Mode. Select that one and press Enter. If you miss the F8 boot options
screen, try again.

You will now boot to Windows in Standard VGA Mode. Your icons and graphics
will appear large, but that's the way that mode looks. Now, find your
downloaded ATI driver file (the .zip file) double click it and follow
on-screen instructions. The Installer will unzip the driver file, put all
the files in C:\ATI and automatically run the setup.exe program.

Good luck,


Hi freddy, I did uninstall the old ones. I went so far as to format the
partition and reinstall Windows. The initial install of Windows with the
windows driver fails, and it worked just fine before when the video card was
the same but the CPU was different.




Well, it's hard diagnosing problems from a distance with only knowing part
of the story. Here is more information on your situation I found:

ATI has this posted in their knowledge Base:

737-24498: Windows Vista: Code 43 Error in Device Manager in Systems with
ATI AGP Cards and Nforce3 Chipset Motherboards

The information in this article applies to the following configuration(s):
Windows Vista 32 or 64 bit
Catalyst Display Driver 7.1 for Vista
Radeon® X1950 AGP series
Radeon® X1600 AGP series
Radeon® X1300 AGP series
Radeon® X850 series
Radeon® X800 series
Radeon® X700 series
Radeon® X600 series
Radeon® X550 series
Radeon® X300 series
Radeon® 9800 series
Radeon® 9700 series
Radeon® 9650/9600 series
Radeon® 9550/9500 series
Attempting to install the graphics driver on a system containing an NVidia
NF3 chipset and an ATI AGP graphics adapter may result in the driver failing
to install and the 3D engine not activating.

In Windows Vista 32bit or 64bit versions, the Device Manager will show a (!)
mark and the AGP card will operate in PCI mode only. When the properties of
the device are shown, the error code will show as code 43.

This issue has been seen with other AGP chipsets such as VIA and SiS but has
since been resolved by chipset driver updates from these manufacturers.

AMD’s AGP adapters require correctly functioning AGP support from the
operating system in order to run the WDDM driver under Vista. This WDDM
driver has no way of working around the absence of AGP support.

Please contact NVidia Corp. ( for more information on this

It seems that updated chipset drivers, which include the AGP drivers for
Vista, may be the source of your problem. At least that's the way I
understand that.



Hi freddy, thanks. I think that might be the problem. nVidia's support for
the NF3 chipset seems to be spotty at best. I'll try contacting them.

I'm curious why it worked fine with the older CPU.




Why your system worked with the former CPU? I have no way of knowing for
certain, but I'll guess that it has something to do with the duel core
configuration of the Opteron. Perhaps someone with knowledge in this area
can provide a technical explanation. The problem seems to be widespread
among AMD dual core users with motherboards such as you have. At least
that's my take on the situation.


Nut Cracker

I would check with MSI to verify that the Opt180 is actually supported by
the board. There might be a CPU microcode update that is required, and thus
a bios update may be needed (if you arent running the latest version, that

I have an Opt175 running in an ASrock939-Dual SATA II board, and have no
problems with XP or Vista Business. There arent enough Vista64 drivers for
my board to warrant using that at this time, so im using Vista Buisness

Very solid system ...

- NuTs


Hi Nut Cracker, I've been doing some research and have found the problem
relates to nForce 3 motherboards with dual core AMD processors. Those with
ATI video cards are stuck with code 43 or running the processor in single
core mode.

The ball is in nVidia's court to fix it, and I'm optimistic they're going to
do so, as they've known about the problem for many months now. They're
official stance is "nForce 3 chipsets are not supported in Vista".

BTW, to answer your question, the Opteron 180 is supported in the board.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question