XP with BIOS clock set to UTC?


4

46kmz5j02

I have a dual-boot system, running XP Pro and Debian linux.
After switching from the Debian stable release ("sarge") to the
testing version ("etch"), I kept seeing a message on linux boot
about "Superblock last write time is in the future. Fix? yes".

The boot proceeds normally after that, but I don't like
inexplicable error messages, so I did some searching on the net.
Apparently, it had something to do with my bios clock being set
to local time, rather than UTC. The recommended "fix" was to
set the bios clock to UTC, which I did. However, when running
XP, my system clock will periodically reset itself to the
hardware clock, and the time jumps ahead four hours.

I found some articles about a registry key called
"RealTimeIsUniversal", and I tried that, but it didn't help. I
disabled the Windows Time Service, since I use a third-party
application to synchronize my system clock to 0.us.pool.ntp.org
a few times per day, but something is still resetting the system
time to the bios clock every so often.

Is there a way I can get these two operating systems to agree on
how to set a clock?
 
M

Malke

I have a dual-boot system, running XP Pro and Debian linux.
After switching from the Debian stable release ("sarge") to the
testing version ("etch"), I kept seeing a message on linux boot
about "Superblock last write time is in the future. Fix? yes".

The boot proceeds normally after that, but I don't like
inexplicable error messages, so I did some searching on the net.
Apparently, it had something to do with my bios clock being set
to local time, rather than UTC. The recommended "fix" was to
set the bios clock to UTC, which I did. However, when running
XP, my system clock will periodically reset itself to the
hardware clock, and the time jumps ahead four hours.

I found some articles about a registry key called
"RealTimeIsUniversal", and I tried that, but it didn't help. I
disabled the Windows Time Service, since I use a third-party
application to synchronize my system clock to 0.us.pool.ntp.org
a few times per day, but something is still resetting the system
time to the bios clock every so often.

Is there a way I can get these two operating systems to agree on
how to set a clock?
No. This is a known issue when dual-booting Windows and Linux.
Basically, you need to decide which OS will get adjusted. Windows uses
Local Time and *nix uses UTC. If you set everything to Local Time, then
twice a year (assuming you live somewhere that uses DST) you will need
to manually adjust your Linux time. If you set everything to UTC, then
Windows will be off.

On the only machine on which I dual-boot (XP and SUSE 10.1) I have
everything set to UTC because I almost never boot into Windows. If you
use Windows regularly on the dual-booting machine, you should use Local
Time and deal with the time issues in Etch the way you have.

Sorry there isn't an easier way, but there you have it. I suppose you
could get around it by scrapping the dual-boot and just installing
Windows in Sarge under VMWare (assuming the box has enough RAM).

Malke
 
G

Guest

I've always had my BIOS clock set to local time, and in this case Windows is
happy. Then I just adjusted the clock settings for my Linux installation. I
don't use Debian (I use Ubuntu/Kubuntu which is based on Debian) so I'm not
familiar with this error.

If you want to use UTC time however, you'll have disable Windows from
automatically synchronizing it's time. Double click on the System Clock, go
to Internet Time, and uncheck the Automatically Synchronize box. You may also
have to set the time zone to Greenwich Mean Time also.

-Dan
 
R

Rock

I've always had my BIOS clock set to local time, and in this case Windows
is
happy. Then I just adjusted the clock settings for my Linux installation.
I
don't use Debian (I use Ubuntu/Kubuntu which is based on Debian) so I'm
not
familiar with this error.

If you want to use UTC time however, you'll have disable Windows from
automatically synchronizing it's time. Double click on the System Clock,
go
to Internet Time, and uncheck the Automatically Synchronize box. You may
also
have to set the time zone to Greenwich Mean Time also.
Would you please quote at least a portion of the message to which you
respond. Otherwise your posts are out of context. You might not realize
it, since you're using the web interface (which btw is clunky and basically
awful) that this is a newsgroup, not a forum or board. Many people access
it using a newsreader and only download the latest messages so we don't see
the other messages in the thread. Thanks.
 
G

Guest

Rock said:
Would you please quote at least a portion of the message to which you
respond. Otherwise your posts are out of context. You might not realize
it, since you're using the web interface (which btw is clunky and basically
awful) that this is a newsgroup, not a forum or board. Many people access
it using a newsreader and only download the latest messages so we don't see
the other messages in the thread. Thanks.
Sure, sorry about that, I didn't realize it. Thanks for pointing it out.

I do dislike the web interface, so maybe I'll give a newsreader a shot.

-Dan
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top