Workgroup Printer Sharing


M

_M_

Have a home network setup this way:

1 PC - Workgroup "MSHOME"
3 Laptops - Workgroup "MSHOME"

PC wired into a wireless router. Laptops connected wirelessly to router. All
machines can "see" each other, but cannot get to any shared folders or
Printers. All machines running XP sp2. Get error about not having
permission to access this network resource. What did I miss ???

TIA
 
Ad

Advertisements

L

Lanwench [MVP - Exchange]

_M_ said:
Have a home network setup this way:

1 PC - Workgroup "MSHOME"
3 Laptops - Workgroup "MSHOME"

PC wired into a wireless router. Laptops connected wirelessly to
router. All machines can "see" each other, but cannot get to any
shared folders or Printers. All machines running XP sp2. Get error
about not having permission to access this network resource. What
did I miss ???

TIA

Add each user account & password identically on each machine.
 
G

Guest

Hi -

Apparently simple file sharing is disabled on the machines. If that's the
case, in order to access a shared resource the user on the remote machine
must be logged into with a valid user account on the the machine hosting the
resource. Sounds like you need to create some users on the machines, that's
all.

hope this helps -
 
C

Chuck

Have a home network setup this way:

1 PC - Workgroup "MSHOME"
3 Laptops - Workgroup "MSHOME"

PC wired into a wireless router. Laptops connected wirelessly to router. All
machines can "see" each other, but cannot get to any shared folders or
Printers. All machines running XP sp2. Get error about not having
permission to access this network resource. What did I miss ???


Are you running XP Home, XP Pro, a combination, other? All of this makes a big
difference.

On any XP Pro computer, check to see if Simple File Sharing (Control Panel -
Folder Options - View - Advanced settings) is enabled or disabled. With XP Pro,
you need to have SFS properly set on each computer.

On XP Pro with SFS disabled, check the Local Security Policies (Control Panel -
Administrative Tools). Under Local Policies - Security Options, look at
"Network access: Sharing and security model", and ensure it's set to "Classic -
local users authenticate as themselves".

On XP Pro with SFS disabled, if you set the above Local Security Policy to
"Guest only", enable the Guest account, using Start - Run - "cmd" - type "net
user guest /active:yes" in the command window. If "Classic", setup and use a
common non-Guest account on all computers. Whichever account is used, give it
an identical, non-blank password on all computers.

On XP Home, and on XP Pro with Simple File Sharing enabled, make sure that the
Guest account is enabled, on each computer. Enable Guest with Start - Run -
"cmd", then type "net user guest /active:yes" in the command window.

On XP Pro, if you're going to use Guest authentication, check your Local
Security Policy (Control Panel - Administrative Tools) - User Rights Assignment,
on the XP Pro computer, and look at "Deny access to this computer from the
network". Make sure Guest is not in the list. Look at "Access this computer
from the network", and make sure that Everyone is in this list.

Do any of the computers have a software firewall (ICF / WF, or third party)? If
so, you need to configure them for file sharing. Firewall configurations are a
very common cause of (network) browser, and file sharing, problems.
 
O

Okie Noah

I had very similar trouble just couple of days ago.
If you are running ZoneAlarm or ZoneAlarm Pro, dis-engage Zone Alarm.
In fact, just unload it in the Laptops, not in your Server.
Try it see it works. Reload Zone Alarm one at a time and make sure
Firewall Zone IP Addresses are inclusive to each of your Laptops and the Server.


| Have a home network setup this way:
|
| 1 PC - Workgroup "MSHOME"
| 3 Laptops - Workgroup "MSHOME"
|
| PC wired into a wireless router. Laptops connected wirelessly to router. All
| machines can "see" each other, but cannot get to any shared folders or
| Printers. All machines running XP sp2. Get error about not having
| permission to access this network resource. What did I miss ???
|
| TIA
|
|
 
Ad

Advertisements

J

jayesh

just make sure you are enabled access to network resources
in xp machine.By default its turned off.Thers an
option "allow others to connect to resources in my
computer" under sharing and security.each machine has to
enable it.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top