Can't change workgroup name


G

Guest

I'm setting up my home network on XP. I have my desktop and laptop both
connecting to the Web through a router (laptop is wireless; desktop connects
directly to router).

I have run the network setup wizard on both computers but on the desktop it
doesn't seem to accept the new workgroup name. I go through all the steps
including naming the workgroup to match the workgroup name on the laptop.

But, I keep getting the message (on the desktop) that access is denied to
the workgroup. When I try to run the setup wizard again on the desktop, when
I get to the step of naming my network, it still shows the name MSHOME, and
not the new network name I entered previously.

Should I try changing the laptop to the network name of MSHOME? On the
Network Places on the laptop it is "seeing" both computers listed, but I
can't actually access anything even though I've enable file sharing and
printer sharing on both computers.

When I troubleshoot the network it suggests that computers on the network
might be sharing a name but both computers have distinctive names.

As for firewalls, is it safe for me to disable them if that is what is
causing the inaccessibility?

Thanks so much!
 
Ad

Advertisements

H

Hans-Georg Michna

I have run the network setup wizard on both computers but on the desktop it
doesn't seem to accept the new workgroup name. I go through all the steps
including naming the workgroup to match the workgroup name on the laptop.

But, I keep getting the message (on the desktop) that access is denied to
the workgroup. When I try to run the setup wizard again on the desktop, when
I get to the step of naming my network, it still shows the name MSHOME, and
not the new network name I entered previously.

Carolyn,

I can't be sure what causes the problem, but you can first try
to change the workgroup name directly, rather than by running
the wizard.

You can do that by right-clicking on My Computer, selecting
Properties, clicking on the Computer name tab, then clicking on
the change button.

You should now see your computer's name, which must be unique in
the network, and your workgroup name, which you want to (but
don't have to) be equal for the computers in your network.

Change it and see whether the change is accepted.
When I troubleshoot the network it suggests that computers on the network
might be sharing a name but both computers have distinctive names.

Are these names simple? You could try names no longer than 14
characters and without spaces for a test.
As for firewalls, is it safe for me to disable them if that is what is
causing the inaccessibility?

Not if you have an Internet connection and no other firewall,
like in a router.

What you can easily do though is unplug your Internet
connection, then disable the firewalls for a test, just to see
whether they harbor the problem.

Be sure though to re-enable the firewalls before reconnecting to
the Internet though. Only if you connect through a router that
has its own firewall, then you are reasonably safe from outside
attacks.

But on the long run I recommend to leave the firewalls enabled.
They would, for example, protect you from malware that comes
into your network on a visitor's computer.

Hans-Georg
 
Ad

Advertisements

P

Poprivet

Hans-Georg Michna said:
Carolyn,

I can't be sure what causes the problem, but you can first try
to change the workgroup name directly, rather than by running
the wizard.

You can do that by right-clicking on My Computer, selecting
Properties, clicking on the Computer name tab, then clicking on
the change button.

You should now see your computer's name, which must be unique in
the network, and your workgroup name, which you want to (but
don't have to) be equal for the computers in your network.

Change it and see whether the change is accepted.


Are these names simple? You could try names no longer than 14
characters and without spaces for a test.


Not if you have an Internet connection and no other firewall,
like in a router.

What you can easily do though is unplug your Internet
connection, then disable the firewalls for a test, just to see
whether they harbor the problem.

Be sure though to re-enable the firewalls before reconnecting to
the Internet though. Only if you connect through a router that
has its own firewall, then you are reasonably safe from outside
attacks.

But on the long run I recommend to leave the firewalls enabled.
They would, for example, protect you from malware that comes
into your network on a visitor's computer.

Hans-Georg

To add to this, firewalls are usually the source of such a problem. Usually
it's a simple matter of checking the firewall log and permitting the blocked
connections from each machine on each machine.

Pop`
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top