WMI through firewall


F

Fabricio Tofoli

What ports should I open on the XP personal firewall to make the computer
accessible using WMI remotelly?

Thanks,
Fabricio
 
Ad

Advertisements

P

Philip Nunn [MSFT]

WMI cannot be made remotely accessible on XP Personal.
 
T

Torgeir Bakken \(MVP\)

Philip said:
WMI cannot be made remotely accessible on XP Personal.
Hi

I wonder if the OP with "XP personal firewall" meant "XP personal" or
did he mean "personal firewall" that comes with XP...
 
P

Philip Nunn [MSFT]

Torgeir has a good point! I may have misunderstood the question. Fabricio,
if by personal firewall you mean the personal firewall on a Windows XP
Professional machine (and not the firewall on a Windows XP Home Edition --
aka Personal -- machine), then it is possible to remotely manage the box
using WMI.

Since, WMI uses DCOM for remoting, enabling DCOM across the firewall should
allow it work. Below is a link I found on MSDN that may be of help.
http://msdn.microsoft.com/library/en-us/dndcom/html/msdn_dcomfirewall.asp?frame=true

A couple of other links that might be relevant:

HOWTO: Configure RPC Dynamic Port Allocation to Work with Firewall
http://support.microsoft.com/default.aspx?scid=kb;en-us;154596

http://groups.google.com/[email protected]



--
Philip Nunn [MSFT]
This posting is provided "AS IS" with no warranties, and confers no rights.
Use of included script samples are subject to the terms specified at
http://www.microsoft.com/info/cpyright.htm.
Philip Nunn said:
WMI cannot be made remotely accessible on XP Personal.

--
Philip Nunn [MSFT]
This posting is provided "AS IS" with no warranties, and confers no
rights. Use of included script samples are subject to the terms specified
at http://www.microsoft.com/info/cpyright.htm.
Fabricio Tofoli said:
What ports should I open on the XP personal firewall to make the computer
accessible using WMI remotelly?

Thanks,
Fabricio
 
Joined
Sep 29, 2009
Messages
2
Reaction score
0
The only advice I've found on the net is to disable the XP firewall in order to allow the use of taskkill across a Windows network. This is not an acceptable answer. The correct answer is to create a firewall exception for the following ports (I figured this out using Windows Firewall's security log, btw):

TCP 135
TCP 4168
UDP 9256

You're welcome.
 
Ad

Advertisements

Joined
Jan 16, 2012
Messages
1
Reaction score
0
[Solution]

if you don’t want to turn off firewall on target machine then do this:

on target machine go to cmd.exe and type following command:

netsh firewall set service RemoteAdmin enable

Read my complete article on remote WMI.

Max
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

Copy through WMI 2
Remote install through WMI 3
WMI filtering for GPO Firewall settings 0
WMI 0
Wmi 0
Wmi 0
Where is the Windows GUI equivalent for this WMI firewall setting? 5
Run WMI within WMI 0

Top