Win32_Processor: WMI: Access denied



When I open WMI Control properties I get on the general tab:

Failed to initialize all required WMI classes:

Win32_Processor: WMI: Access denied
Win32_WMISetting: Successful
Security information: Successful
Win32_OperatingSystem: WMI: Access denied

I can't open any other tab, except general tab.

I have tried stopping the WMI service, deleting the repository in WBEM,

restarting, reinstalling XP Pro SP2 (upgrade option) to no avail.

Can any one help me with this problem? I've XP Pro SP2

Many thanks in advance


I've solved the problem. My problem was caused by Norton Firewall'
protect my product option. Uncheck "Protect my product" option on the
general tab in the options dialog, and "WMI: Access denied" error will
go away. At least it did in my case.
Jan 25, 2006
Reaction score
To reinstall WMI, do the following:

Go to the directory %WinDir%\Inf
Search for the file wbemnt5.inf or wbemoc.inf
Copy the file to another file, say wbemoc_reinstall.inf
Add the following lines to the top of this file:


Run the following command:
sysocmgr /i:wbemoc_reinstall.inf /f

A setup would comeup, asking to reinstall WMI.
Complete the setup wizard, and WMI would start functioning again.
Enjoy :)

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question