"Win32_Processor: WMI: Access denied" and "Win32_OperatingSystem: WMI: Access denied"


M

Mark Jennings

Hello Folks,

I was trying to install SMS 2003 Advanced client on one of our laptops (Dell
Inspiron 4000 512Mb RAM) when I came across some WMI problems.
When I connect to the machine via Computer Management it says that it fails
to initialise all WMI classes:

The text reads:

Failed to initialise all required WMI classes:

Win32_Processor: WMI: Access denied
Win32_WMISetting: Successful
Security information: Successful
Win32_OperatingSystem: WMI: Access denied

I have tried stopping the WMI service, deleting the repository in WBEM and
restarting to no avail.

Can anyone help me fix this WMI?

Many thanks in advance,

Mark Jennings
 
Ad

Advertisements

T

Torgeir Bakken \(MVP\)

Mark said:
Hello Folks,

I was trying to install SMS 2003 Advanced client on one of our laptops (Dell
Inspiron 4000 512Mb RAM) when I came across some WMI problems.
When I connect to the machine via Computer Management it says that it fails
to initialise all WMI classes:

The text reads:

Failed to initialise all required WMI classes:

Win32_Processor: WMI: Access denied
Win32_WMISetting: Successful
Security information: Successful
Win32_OperatingSystem: WMI: Access denied

I have tried stopping the WMI service, deleting the repository in WBEM and
restarting to no avail.

Can anyone help me fix this WMI?
Hi

Try (using e.g. Start/Run, or a command prompt):

regsvr32 %windir%\system32\atl.dll
regsvr32 %windir%\system32\netshell.dll
regsvr32 %windir%\system32\hnetcfg.dll
regsvr32 %windir%\system32\netcfgx.dll
regsvr32 %windir%\system32\netman.dll

If that doesn't fix it, a lot of good information in this one about
repairing WMI:

From: Ivan Brugiolo [MSFT] ([email protected])
Subject: Re: Windows XP WMI Reinstall
Newsgroups: microsoft.public.win32.programmer.wmi
Date: 2004-04-21 00:46:56 PST
http://groups.google.com/[email protected]


WinXP Pro only:
If nothing in the link above helped, you might want to follow
the procedure here and see if it helps:

How To Reset Security Settings Back to the Defaults
http://support.microsoft.com/?kbid=313222
 
M

Mark Jennings

You, sir....are a GENIUS! Thankyou so much! The regsrv stuff didnt work but
the Ivan Brugiolo solution did! Thank you for pointing me in that direction.

Many thanks,

Mark Jennings
Torgeir Bakken (MVP) said:
Mark said:
Hello Folks,

I was trying to install SMS 2003 Advanced client on one of our laptops (Dell
Inspiron 4000 512Mb RAM) when I came across some WMI problems.
When I connect to the machine via Computer Management it says that it fails
to initialise all WMI classes:

The text reads:

Failed to initialise all required WMI classes:

Win32_Processor: WMI: Access denied
Win32_WMISetting: Successful
Security information: Successful
Win32_OperatingSystem: WMI: Access denied

I have tried stopping the WMI service, deleting the repository in WBEM and
restarting to no avail.

Can anyone help me fix this WMI?
Hi

Try (using e.g. Start/Run, or a command prompt):

regsvr32 %windir%\system32\atl.dll
regsvr32 %windir%\system32\netshell.dll
regsvr32 %windir%\system32\hnetcfg.dll
regsvr32 %windir%\system32\netcfgx.dll
regsvr32 %windir%\system32\netman.dll

If that doesn't fix it, a lot of good information in this one about
repairing WMI:

From: Ivan Brugiolo [MSFT] ([email protected])
Subject: Re: Windows XP WMI Reinstall
Newsgroups: microsoft.public.win32.programmer.wmi
Date: 2004-04-21 00:46:56 PST
http://groups.google.com/[email protected]


WinXP Pro only:
If nothing in the link above helped, you might want to follow
the procedure here and see if it helps:

How To Reset Security Settings Back to the Defaults
http://support.microsoft.com/?kbid=313222


--
torgeir, Microsoft MVP Scripting and WMI, Porsgrunn Norway
Administration scripting examples and an ONLINE version of
the 1328 page Scripting Guide:
http://www.microsoft.com/technet/scriptcenter/default.mspx
 
Ad

Advertisements

S

SMSAdmin1

I have worked with MS on this issue and we were able to resolve thi
issue:

In a managed environment, you will need to modify your group polic
settings for WMI, SMS Agent Host, and SMS Remote Control Agen
services. Add Authenticated Users and give them READ permissions.
Worked like a charm.

NOTES
The problem is likely due to GPO Restricted Group affecting the SM
Agent Host Service. If a policy is defined in Computer Configuration
Windows Settings | Security Settings | System Services | SMS Agen
Host, I would consider adding “Authenticated Users” Read, as well. I
any policies are defined under System Services, they will likel
needthis alteration, as XP SP2 addresses a service impersonatio
vulnerability


-
SMSAdmin
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top