Win2k Server and RAID-5 issue (HELP!)



I have a Win2k Server machine with a Promise SX6000 running six 200Gb HDDs
in a RAID5 configuration.

We lost a drive, then had a power hit, which of course set the array into

After rebooting and attempting to recover, the PAM software (Promise Array
Management) showed two of six drives as online, but no longer a member of
the array, which prevented us from being able to rebuild the array. There
was no method to add a prior disk back into the array via the PAM interface.

After walking through the recovery guides, it was decided that the BIOS
recovery option was out last resort, so why not give it a try? We did,
carefully following the steps, and it worked! The array is back online and
shows a healthy status via the Promise Array BIOS at boot up and in the PAM
software under Win2k.

The problem is - once we boot into Win2k Server, the array is visible, but
Disk Management shows the space as "Unallocated". Basically, Win2k can see
the drive, the size is correct (1TB), but it appears to be uninitialized.
Disk manager wants to write its "Signature" to the drive, but we have not
tried that as I don't want to risk damaging the data. I do not have a saved
copy of the disk configuration for Win2k, which I think would solve my
problem if I did.

The data is visible via Ontrack EzRecovery Professional software by using
the "Raw recovery" option which scans the array sector-by-sector searching
for files. We are backing up what we can via the Ontrack software, but it
won't be able to recover any files that are fragmented.

Question - is there a way to recover/manually create the Win2k disk
configuration so that we can recover ALL of our data?

Any help would be appreciated.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question