Weird LAN Problem


Dennis Jelavic

Hope someone can help.

1. I have a small network with two computers - one running XP and the
other running Win 2K.
They are networked on a workgroup through a NetComm router which provides
both machines access to the internet.
The Win 2K machine connects to the router thru a DLink DWL G510 wireless
adapter and the XP machine connects to the router via a REALTEK ethernet
adapter. The Netcomm router is configured to provide IP addresses to the two
computers dynamically
Both computers can access the internet thru the router and both computers
can ping the router. The XP machine can ping the Win2K machine but the
win2K machine can't ping the XP machine. (accordingly the XP machine can
"see" the win2K machine in My Network Places => Entire Network => MicroSoft
Windows Network => workgroup name but not vice versa).

2. After trying everything I could think of with no success I reinstalled
Win2K on the machine (and the device driver for the network card) to no
avail. I still had exactly the same problem.

3. I then took out the wireless card from the win2K machine and installed
a SWAN ethernet NIC and got exactly the same results.

4. I then connected the win2K machine directly to the ethernet adapter in
the XP machine, bypassing the router altogether. The XP machine could still
ping the win2K machine but the Win2K machine could still not ping the XP

5. As a final insult to my efforts, I returned the configuration as it
was originally ( at least thru this both machines could get at the internet,
but as the wireless network was originally set without an encryption key,
encryption was set on the router and on the win2K machine. The XP machine
could still access the internet but the win2K machine couldn't. So I removed
encryption from both devices, fully expecting to have internet access again
from both machines. However the XP machine is still OK but I can now no
longer get access to the internet thru the Win2K machine.

6. The IP addresses all seem to be being generated OK and there are no

Can anyone throw any light on what is going on? Or suggest some further
avenues of examination.

Getting desperate

Dennis Jelavic

Dennis Jelavic

Have tried with both firewall activated and not activated with same result.

Dennis Jelavic


I would say you either have a security issue on the XP machine which
prevents connections, such as a firewall, you trying to reference the XP
machine by hostname (not by IP) and the hostname is not recognized, or a
cabling problem.

I have seen this behaviour before with CAT 5 cabling where the pairing was
done incorrectly or a faulty cable.



Dennis, Did you have any luck getting it working? I have the same problem....



I spent a good part of the day yesterday with the almost the EXACT same
Turns out the kerio personal firewall was denying file and printer sharing
from the trusted zone and not asking for permission.
no wonder i couldn't map a drive from xp to w2k.
good luck.

Dennis Jelavic

Thanks jd, but I think my problem is deeper down. I'm now beginning to
think its hardware.

Dennis J


Dennis... I had a win. I went into my system registry on my desktop and did
a search for "restrictanonymous". Mine was set to a "1". Apparently it
needs to be set to "0". From memory there is more than one instance of this.
Hope it helps


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question