VS2005 Assembly problem


V

Vp

Hi

I was runing my PC with VS2005, recently I have installed VS2008,
all of sudden my VS2005 started giving me error like
Could not load file or assembly 'System.EnterpriseServices,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or
one of its dependencies. The system cannot find the file specified.

I have uninstalled VS2008, VS2005 and reinstall VS2005, problem remain
same. I tried to install Asp.net V2.0.05727 using Aspnet_regIIs -i,
but problem still there ? is there any solution ?
 
Ad

Advertisements

M

Manish

Hi,

Most probably you have a different version of the System.EnterpriseServices
assembly in the global cache. Or you don't have it at all.
You need to add the 2.0.0.0 version to the GAC.
In order to do that just drag the file a
"<windows_directory>\Microsoft.NET\Framework\v2.0<your_subversion>\System.EnterpriseServices.dll"
to the "<windows_directory>\assembly\" folder.

Before that just check the properties of the file to be sure it has the
appropriate version number.

Regards,
Manish
www.ComponentOne.com
 
Ad

Advertisements

M

Mark Siedle

Hi

I've run into the same problem. I didn't install any new applications, or do
anything different, just logged in this morning and ran my web app and got
the same error you mention above.

I've tried aspnet_regiis -i, no luck

I've run the repair op for .NET2.0, no luck

I've tried dragging and dropping EnterpriseServices.dll into
C:/Windows/assembly, but that seems to fail (screen refreshes but assembly
doesn't show up in the list).

I stupidly left automatic updates on when I reinstalled windows recently, so
could this be related to a recent update?

Thanks
Mark
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top