VS05, failing to recognize that unit tests exist

  • Thread starter Richard Lewis Haggard
  • Start date


Richard Lewis Haggard

We're using VS05 and today the units tests have stopped working in our
development environment. I'm sure that it is something really silly and
simple but I'll be darned if I can figure out what it is.

Here's a failure example: I created a simple little C# program called Test1.
I added a new class that has a public method Sum, which does the brilliant
function of adding two numbers together and returning the result.

I added a unit test by clicking on "Test->New Test" and selected the Unit
Test Wizard. It wanted to create a test project and this was named
TestTest1. A form opened and I navigated down through the namespaces until I
got to the method to be exercised. I checked this and hit OK. The TestTest1
project was added to the solution and the code to test Sum was created by
the wizard. I modified the test code so that it actually had valid values
with which to work. It all builds but I just don't seem to be able to get
any tests to actually run.

Selecting project Test1 results in the menu command "Test->Start Selected
Test Project with Debugger" being disabled.

Selecting project TestTest1 results in the menu command being enabled but
actuating this command results in "Cannot start test project 'TestTest1'
because the project does not contain any tests."

Right clicking on TestTest1 and selecting "Run Unit Tests" results in no
tests being run The Unit Test Runner appears but has no tests listed in it.

I added another method to ToBeTested called Add, right clicked on project
TestTest1 and selected Add->Unit Test...Again, I navigated down through the
name spaces and selected 'Add'. The method AddTest was created for me in the
test file. However, this time, a dialog appears. "Column 'TestType' does not
belong to table test." What does this mean? I get this same dialog when
trying to run tests sometimes, depending upon how the test run is started.

I've spent hours going around in circles on this. Please help!



Richard Lewis Haggard

Oh! This may be an environmental problem. I deleted the solution's SUO file
and then the problem went away. I suspect that there is an interaction
between VS05, service pack 1, WPF, Enterprise Library, CAB and SCSF and how
the VS05 unit test functionality works. This solution worked on 3 out of 4
machines I tried it on. The remaining machine is still displaying the
"Column 'TestType' does not belong to table test" message box.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question