Volume Shadow Copy Service


E

Edward W. Thompson

OS WINXP Pro

I have found that my preferred backup software, Genie Backup (GBM Pro8) will
not backup and fails with a message indicating the problem relates to the
Volume Shadow Copy Service. I have tried ntbackup and have found the same
problem, that is while the software runs it does not complete and fails with
an error. This is both indicative and confirms the problem relates to
Volume Shadow Copy Service. I have confirmed that all relevant services
(services.msc) are started and I have carried out the following (From
extensive posts on the subject on Google). Similar to many (again from
Google) 'regsvr32 /i swprv.dll' results in a message 'dllinstall failed'
with Return Code 0x8000ffff. So far I have not found a way to run this
entry. As an act of desperation I have run 'sfc /scannow'.

net stop vss
net stopswprv
regsvr32 ole32.dll
regsvr32 vss_ps.dll
Vssvc /Register
regsvr32 /i swprv.dll
Regsvr32 /i eventcls.dll
regsvr32 es.dll
regsvr vssui.dll
regsvr32 stdprov.dll
regsvr32 msxml.dll
regsvr32 msxml3.dll
regsvr32 msxml4.dll

Does anyone have any experience how to overcome this problem? I also
understand I may need to uninstall and reinstall COM+ but haven't got that
far yet. Could problems with COM+ be related to not being able to run
regsvr32 /i swprv.dll? I would appreciate any help to solve this problem.
Other not being able to run GBM8 the machine operates flawlessly, at least
as far as I can tell. As an aside I do have Acronis True Image 10
installed. I understand earlier versions of True Image caused problems with
VSS and I have had installed at some stage earlier versions so I suppose
that may have been the root of the problem
 
Ad

Advertisements

G

Guest

I don't have any solution to offer you, but I am interested in learning
more about your problem since I may have a related problem (I get a blue
screen bad_pool_header error if I try to run ntbackup with shadow copy
enabled).

Have you discovered any useful links related to shadow copy service?

Bob
 
Ad

Advertisements

P

Peter Snow

I have the same problem.

I have done this,

@echo off
REM
REM Batch file for Windows XP and 2003 that attempts to reset the
REM Volume Shadow Copy (VSS) installation.
REM
REM 2BrightSparks Pte Ltd
REM http://www.2BrightSparks.com/
REM
%SYSTEMDRIVE%
cd %SystemRoot%\System32
echo.
echo --- Ignore any messages saying a service is not started.
echo.
Net stop vss
Net stop swprv
regsvr32 ole32.dll
regsvr32 vss_ps.dll
Vssvc /Register
regsvr32 /i swprv.dll
regsvr32 /i eventcls.dll
regsvr32 es.dll
regsvr32 stdprov.dll
echo.

regsvr32 msxml.dll
regsvr32 msxml3.dll
echo.
echo --- msxml4.dll may not be installed and is optional. Ignore the error.
regsvr32 msxml4.dll
echo.
echo ------------------------------------------------------------------------
echo.
echo IMPORTANT: Reboot your computer. After the reboot, open a command
prompt
echo and run the following:
echo.
echo vssadmin list writers
echo.
echo Ensure that all your writers are displayed without errors.
echo.
pause


Which initially ran without an error but it didn't fix my problem. I then
re-installed my com+ following the MS instructions for doing so. I thought
that had fixed my problem but maybe I just didn't test it sufficiently. I
still think it fixed it though but after I shut down and restarted the
following morning, the problem seemed to be back.

I've now run the above batch file again and this time I get a message saying
"DllInstall in swprv.dll failed. Return code was: 0x8000ffff"

When I look in event viewer, I get a new error!

Event Type: Error
Event Source: VSS
Event Category: None
Event ID: 4100
Date: 10/23/2007
Time: 6:42:00 AM
User: N/A
Computer: LAPTOP
Description:
Volume Shadow Copy Service error: Cannot create service 'SwPrv' for the COM+
application 'MS Software Shadow Copy Provider' [0x80070431].

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 43 41 44 43 41 44 4d 43 CADCADMC
0008: 32 37 35 00 00 00 00 00 275.....
0010: 43 41 44 43 41 44 4d 43 CADCADMC
0018: 32 31 32 00 00 00 00 00 212.....

Any ideas anyone? I'm trying to backup my laptop but without VSS it's almost
impossible :(
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top