Vista shortcut icons keep reverting back to default exploer icon.


G

Guest

im running vista home premium and i have added a few new shortcuts to the
desktop.

i have also changed the icons to vista icons i found on the net,

when i first put them on the desktop and assign a vista icon, everything
looks fine,
they show at the medium size, as soon as i turn off and then turn on the
computer
90% of all the new shortcut icons have reverted back to the std explorer
icon with the shortcut small arrow in the left hand cnr
(they are still at the medium size though)

the view i am using is "medium icons".

now,
when i right click the desktop icon and select "classic icons" the correct
icon i assigned does reappear but very small as you would expect.

as soon as i change the view back to medium icons, the icon changes to the
std explorer icon shortcut.

to get them back manually i have to go back and reassign each original icon
back to that shorcut, thats fine until i reboot or turn off and turn back on
in the morning.

i have put all my icons into a seperate file called "icons" and the path to
them is correct.

Also they are not in my temp internet files folder, so that solution does
not work.

Can You Help with a solution to this??

running a toshiba P200, 2ghz core2duo, 2gig ram,
and running vista home premium.

i cannot find a solution anwhere on the net
please try and help me

thanks kevin
 
Ad

Advertisements

D

Don Varnau

Hi,
Try setting the shortcut to "read only" after assigning your custom icon.

Or, if these are internet shortcuts, IE7 may be changing the icons when
checking for a Favicon. Creating a shortcut to iexplore.exe which includes
the URL will make the shortcut a LNK file and E7 should leave it alone. A
side effect is that each shortcut will open in a new window.

Find "IExplore.exe" (probably in Program Files\Internet Explorer)
Right-click and drag IExplore.exe to the desktop and choose "Create
shortcut." Right-click that shortcut> Properties> Target, modify the Target
to include the URL.
Example:
"C:\Program Files\Internet Explorer\IEXPLORE.EXE"
becomes
"C:\Program Files\Internet Explorer\IEXPLORE.EXE" www.yahoo.com
Note a space between EXE" and ww
Rename the shortcut if desired.
Apply the custom icon.
Since it's no longer an Internet Shortcut, it's an .lnk (.LNK) file, IE7
should leave the icon alone.

Hope this helps,
Don
[MS MVP- IE]
 
Ad

Advertisements

G

Guest

This is bogus -- none of these suggestions work.

Don Varnau said:
Hi,
Try setting the shortcut to "read only" after assigning your custom icon.

Or, if these are internet shortcuts, IE7 may be changing the icons when
checking for a Favicon. Creating a shortcut to iexplore.exe which includes
the URL will make the shortcut a LNK file and E7 should leave it alone. A
side effect is that each shortcut will open in a new window.

Find "IExplore.exe" (probably in Program Files\Internet Explorer)
Right-click and drag IExplore.exe to the desktop and choose "Create
shortcut." Right-click that shortcut> Properties> Target, modify the Target
to include the URL.
Example:
"C:\Program Files\Internet Explorer\IEXPLORE.EXE"
becomes
"C:\Program Files\Internet Explorer\IEXPLORE.EXE" www.yahoo.com
Note a space between EXE" and ww
Rename the shortcut if desired.
Apply the custom icon.
Since it's no longer an Internet Shortcut, it's an .lnk (.LNK) file, IE7
should leave the icon alone.

Hope this helps,
Don
[MS MVP- IE]

KiwiKev said:
im running vista home premium and i have added a few new shortcuts to the
desktop.

i have also changed the icons to vista icons i found on the net,

when i first put them on the desktop and assign a vista icon, everything
looks fine,
they show at the medium size, as soon as i turn off and then turn on the
computer
90% of all the new shortcut icons have reverted back to the std explorer
icon with the shortcut small arrow in the left hand cnr
(they are still at the medium size though)

the view i am using is "medium icons".

now,
when i right click the desktop icon and select "classic icons" the correct
icon i assigned does reappear but very small as you would expect.

as soon as i change the view back to medium icons, the icon changes to the
std explorer icon shortcut.

to get them back manually i have to go back and reassign each original icon
back to that shorcut, thats fine until i reboot or turn off and turn back on
in the morning.

i have put all my icons into a seperate file called "icons" and the path to
them is correct.

Also they are not in my temp internet files folder, so that solution does
not work.

Can You Help with a solution to this??

running a toshiba P200, 2ghz core2duo, 2gig ram,
and running vista home premium.

i cannot find a solution anwhere on the net
please try and help me

thanks kevin
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top