USB Mass storage devices fail to install


G

Gary G. Little

This happened first on an upgrade from XP SP2 to RC1, and now on a clean
install. None of my USB mass storage devices would appear in Disk
Management or Computer. Looking at error messages I was seeing a driver
failed to install with a bad parameter. I did a clean install and all of
them appear. However, while working with a 120 GB Seagate FDE, I ran that
unlock utility which changes the capacity of the drive. When first installed
an FDE drive is limited to a partition of 8 meg, requiring the user to
unlock the drive to get the full benefits of FDE and all those gigabytes.
However, again during the install, or reconcilitation of drivers, I can only
assume USB since perse there is no driver for a disk on a Windows system,
the driver failed with "bad paramter". Any thoughts?

System: Precision M70, Pentium M 2.13 GHz
Hitachi 60GB HDD
1 G RAM

Gary G. Little
 
Ad

Advertisements

G

Guest

Yes,I have the same problems.
None of my usb-disks (included usb-disk,usb-hdd,psp,card reader...) can be
installed for the drivers.
1st, vista will find a new hardware,then it reports "search for a friver?"
both choose auto or manully will get the same answer "can not find the
driver".
2nd, I tried the way as WINXP: delete the USB roots' drivers (3 in my
laptop). In XP, it will auto-rescan the drivers for USB roots,then find the
sub-hardwares (ex:USB mass storage drvices). But in RC1, USB roots cant be
install for the driver either... So, nothing found then.
Whats up!

VISTA RC1 x86 5600
AMD MT-28
2G DDR
100G HDD HT
 
G

Guest

Yes,I have the same problems.
None of my usb-disks (included usb-disk,usb-hdd,psp,card reader...) can be
installed for the drivers.
1st, vista will find a new hardware,then it reports "search for a friver?"
both choose auto or manully will get the same answer "can not find the
driver".
2nd, I tried the way as WINXP: delete the USB roots' drivers (3 in my
laptop). In XP, it will auto-rescan the drivers for USB roots,then find the
sub-hardwares (ex:USB mass storage drvices). But in RC1, USB roots cant be
install for the driver either... So, nothing found then.
Whats up!

VISTA RC1 x86 5600
AMD MT-28
2G DDR
100G HDD HT
 
G

Guest

Yes,I have the same problems.
None of my usb-disks (included usb-disk,usb-hdd,psp,card reader...) can be
installed for the drivers.
1st, vista will find a new hardware,then it reports "search for a friver?"
both choose auto or manully will get the same answer "can not find the
driver".
2nd, I tried the way as WINXP: delete the USB roots' drivers (3 in my
laptop). In XP, it will auto-rescan the drivers for USB roots,then find the
sub-hardwares (ex:USB mass storage drvices). But in RC1, USB roots cant be
install for the driver either... So, nothing found then.
Whats up!

VISTA RC1 x86 5600
AMD MT-28
2G DDR
100G HDD HT
 
Ad

Advertisements

G

Guest

OK,Gary. By wasting whole night's time, I found out the solution.
Simple browse the drivers from "x:\windows(include the subdirs)". OK!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top