"problem ejecting USB mass storage device"


M

Mac

i saved a file on my flashdisk then when i tried to 'safely remove hardware',
theres a prompt " problem ejecting USB mass storage device,...try to remove
later",i waited a couple of minutes then tried to remove, same thing prompt
appeared..theres no problem in detecting a device when i use the usb, but the
problem occured when im going to remove the hardware,theres a prompt of
"problem ejecting usb mass storage device"..i even tried to connect my mp3
and hardisk but same thing happened,i cant safely remove them..what should
imo going to do?pls help!THANKS!
 
Ad

Advertisements

W

Wandering

Please do NOT use "Safely Remove" for flash drives. Just plug them in and
unplug them. If you used it with your Media Player, shut down the player
before removing.

Why would you try to "Safely Remove" your hard drive?

For most folks, "Safely Remove" has no practical use. It is mostly used with
devices that have delayed write enabled, and flash drives do not. The eject
function is fairly safe, but generally unnecessary as well. If you use it
with multi-card readers, it removes the reader, not the card.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top