Unable to install .msi packages, error 1325



When trying to install any .msi package on Vista Business SP1 I get an error
1325<username> is not a valid short filename. This only happens with my
domain user account which is 9 characters long. This does not happen when
logged in locally or with my domain admin account. It is specific to Vista,
though. On my XP laptop it's fine. I can install whatever I want. I'm the
admin at this site so my user acct has admin rights to all the clients on my
network. I'm trying to test Vista just to get a good feel for it in case the
folks at my corporate office get a wild hair and decide to start rolling it

It's just odd that it's only on the Vista machine that I'm trying to set up
and not on any of my XP machines and that it's only .msi installer packages
regardless of who assembled it.


That has been suggested on many different places. That might be something if
I could install anything, but I can't. Not even that tool. And like I said,
they will install just fine with a different account, they will install just
fine on a Windows XP system with the same account. I've already formatted
and reloaded the test system as well just to make sure that it wasn't a
problem with the first load.

Mark H

Go into the user account giving problems and delete all files located in
TEMP directories.
This may require a little manual searching through directories. (Or, you can
use the search feature, but may not be as effective.)

Then, try again.


I have the same issue. I think it is because we use offline files. If you
look at where the Personal directory is pointed to, like:

\\SERVER\DriveMapping\username\My Documents

I don't think it is because of the length of the username, but rather the

Open regedit

Go to
Shell Folders

For the My Music, My Pictures, and My Videos values change from the explicit
\\SERVER\Private$\%username%\My Documents\My Pictures
%userprofile%\My Documents\My Pictures

where %userprofile% is something like c:\User\username

You could also try to set your personal directory back to it's default path.


Nope. The funny thing is that I could create a local account with the same
name and it works without a problem. I even tried installing Windows
Installer 4.5 on it without any luck.


I've been thinking the same thing. I tried just putting the drive letter
path in, but only for the Documents folder. I'll try it for the others, too.


Well, this has proven to be VERY interesting. If I edit the registry keys
and don't change them back, then my folder on the server gets deleted once I
reboot the client. This is a big problem. Thank goodness I have backups and
Vista isn't getting rolled out to anyone anytime soon.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question