UAC with a specific program problem



I installed an application as administrator.
When I launch the program, I always get an Allow or Deny prompt (ya know
like the commercial). Other programs don't have this prompt when I start them.

Then, I log in with a standard user account and the same program that had
the UAC prompt no longer prompts me.

Why is this? I would like it to be the same way when logged in as an

I don't see any rhyme or reason to any of this.


Thanks for the reply but this does not fix the problem.
It still prompts after doing this.

Any other advice to avoid this time wasting, finger tiring, mouse
degenerating hurdle?

Ronnie Vernon MVP


What type of program is this? Any program that asks for access to the entire
system is going to need aministrator permissions.

If a program is completely compatible with Vista, it should not be prompting
for permissions. Here is some information, originally posted by MVP Jimmy
Brush that describes this process.

Windows Vista does not control the UAC prompts - your application does.

It is up to your app to include a manifest file (either compiled into
the app or as a seperate file, yourapp.exe.manifest) that tells
Windows Vista how it needs to run.

Your app can tell vista one of three things:

- It never needs admin privileges, even if the user is logged in as an
admin (asInvoker)

- It needs admin privs if the user is an admin, but it can also run if
the user is not an admin (highestAvailable)

- It must have admin privs to run, and standard users cannot run it

If your application has no manifest, then the first option (no admin
privs) is assumed, unless your app is determined to be an installer,
then the third option (requiresAdministrator) is assumed.

Microsoft MVP - Windows Shell
Windows Vista Support FAQ -

Mark Russinovich: Inside Windows Vista User Account Control


I appologize, I thought this would be a general issue instead of technical
but it turned out to be technical. The problem was on our companies software.

It didn't run or had errors so I thought I needed to create a manifest. Then
the manifest worked but we kept getting prompt. So I thought it was a general
user setting maybe.

Well I recompiled the program without the manifest (or let Visual Studio
generate its own and embed it) and it worked without prompt.

Vista does make it hard for companies to update their software compatibility
issues and the lines between general settings and technical settings are so
blurred that its hard to tell where the problems are coming from.

Ronnie Vernon MVP


I agree with your "blurry" statement.

I'm glad you were able to make the software work properly.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question