Two UAC Related Phenon trying to workaround--For you UACanistas



This applies to a dual boot box where you have XP on the first drive, and
Vista on the 2nd. Operating most of the time from Vista, I find it
convenient like a lot of people to access my XP desktop by a short cut. You
don't get the full functionality of XP as if you booted, but you can any
access files and folders very well including windows. By that I mean, you're
not going to fire up XP's Outlook Express from Vista, and you're not going
to hit a start button on XP from Vista and get the Start Menu and XP all
programs although you could shortcut any of these to the XP desktop and then
easily hit them from Vista. You're also not going to get things done on XP
from the XP command prompt while in Vista.

Dragging and Dropping from my Vista folder directly into an XP desktop
folder on dual boot

1) Even when I make a few moves to disable UAC (to test behavior of Vista
under different conditions of course--perish the thought I'd dare leave it
off and fall from grace as a UAC team blog reader) I notice that if I want
to move a file from a Vista folder on the Vista desktop into XP by direct
drag and drop I'm denied access. What I have to do is to drag to the desktop
and then drag to the folder. A small thing but I'm also interested in why
although I'm sure this is a UAC dictated security phenomenon.

2) The second curious thing I've noticed several times I can't solve
directly. Here's how it works on Vista--I've never seen it in XP and XP of
course doesn't have UAC.

I like to make a quick note into notepad or if I'm in a hurry I'll put a
link or some copy I'm reworking just for tips or hints often into notepad.
These are often things I can't paste into something else quickly like email
or Word or Wordpad.

I also haven't seen this happen in Word or Wordpad whether they are a
shortcut form XP or not. If I use the Notepad that I've made in a folder on
my XP desktop and drag copy it to my Vista desktop>then add to it on the
Vista desktop and try to close it and save it it won't let me. It puts up a
"save as" dialogue box and has "save as ANSI" which it refuses to do; it
won't save in any other format either.

The workaround is to make a new notepad by right clicking the Vista
desktop>copying whatever was in the XP notepad and recently added to it
while on the Vista desktop. I can close the one I made in Vista no problem.

Obviously UAC has a problem with the notepad that I dragged and dropped from
the notepad on the XP desktop to the Vista desktop. I just wondered from
someone who is versed in UAC enough to help me understand what is going on
here why this happens and what added security it gives me. I suppose it has
to do with an invader taking over and dropping files with malicious material
in them.

Some might say--just put the copy in 3rd party "post its," or use the Vista
sidebar tool for this or use Wordpad, Word or One Note is convenient for
this. All that is of course true. But I wanted to understand these. Also
I don't let the sidebar startup--I just don't find anything it does that I
can't do easily without it and I'm not enamoured with its design. I would
be if I were 10 no offense to those of you who are really into the sidebar
or Sidebar Geek either. I took it out of the startup lineup in
Vista --often msconfig won't do this because there can be as many as a dozen
starting places for a program in XP but it worked fine for this.




Jimmy Brush


1) Is your Windows XP partition formatted with NTFS? I am assuming it is.
Without knowing more information about the setup of your system, it would
seem to me that you are hitting up against NTFS permissions issues. This is
not technically a UAC issue, as this behavior would have presented itself if
you dual booted XP installs using only limited accounts, but since nobody
does that the fact that it is *technically* a different issue is a moot

The way Windows handles NTFS permissions in a UAC environment is bad. Really
bad. Sometimes it helps you along, other times it leaves you out in the cold
with such helpful messages as "Access Denied (no other options, just an OK
button)", "You need permission from <yourself> to access these files", and
"I couldn't give you access, try editing security yourself."

I am very disappointed in this behavior.

Anyway, back to your problem ...

I find it curious that you say you do not get an "access denied" error when
dragging from your Vista desktop to your XP desktop ... are you sure this is
the case? I just tested this out myself, and I get an access denied error
regardless of how I try to create a file on my XP desktop - I have to
elevate in order to complete the task.

As I'm sure you noticed, when you first accessed your XP Documents and
Settings folder from Vista, you had to elevate and have it "give you
permission" to access it. Turns out, this process only gave you read
permission, not write permission. In order to have write permission, you
will need to add it manually.

Part 1: Open an Administrator Explorer window

-Click Start
-Type: explorer
-Right-click Windows Explorer
-Click Run As Administrator
This will open an "Administrator" explorer window. Every action that you
take from this window will be executed with full Administrator permissions.

Part 2: Change security settings

-Find the folder you need access to from the Administrator Explorer window
-Right-click it
-Click Properties
-Click the Security Tab
-Click Edit
-Click Add
-If you are the only one that needs modify access to this file, type your
username and press enter. Otherwise, type "Users" and press enter.
-Click the checkbox under Allow next to Full Control
-Click OK
-Click OK

2) I am afraid I got confused when trying to follow the steps you mentioned.
By "notepad" are you referring to notepad.exe or a notepad file? In any
case, try changing the security as I mentioned above and see if that fixes
the problem.

- JB

Vista Support FAQ

Chad Harris

Thanks Jimmy. By notepad I meant notepad.exe --a notepad I would make just
to paste some info in it on the fly or a tip, etc.--nothing like a notepad
file. Sorry if I needed to include more info. Yep XP is NTFS--I never used
FAT with and could find few reasons to compared with compelling reasons to
use NTFS. I enjoy reading your posts on UAC. I try hard to embrace all the
logic of what they are making with it, but I hope they take a good look at
it and find a way to deploy it much better. I find most disappointing
beling blocked from accessing some Vista folders while on XP and
particularly not being able to access the My Documents folder from Vista on
XP no matter how much I play with security tab permissions.

i am getting ready to format a Vista drive now, so I have been saving some
of the folders from the Vista desktop onto my XP desktop folder which after
careful consideration I've named Vista Saved. I think that I am able to
do this because I have turned off UAC on Vista enough including secpol's
last 6 permissions entries at Local Policies>User Rights Assignments to
avoid interference. When I get back on my Vista boot I'll test this.

Thanks for those steps. I assume you mean for them to be done while on
Vista. and I'm going to give them a shot. I'll let you know and try to be
clear with each step of dragging I do.


Jimmy Brush

Yes, I was talking about about doing all the steps on Vista.

And if you are trying to access the documents folder on vista from xp, make
sure you are going to \users\USER\Documents, as "My Documents" is one of
those nasty junctions that will probably always give you access denied.

Like I mentioned before, this is a sore point with me as well - it's not
really UAC's fault here, it's really the fault of NTFS permissions being
complicated and not having a friendly UI to help you with editing them. In
XP you didn't have to deal with this because running as Administrator gives
you access to pretty much anything, while in Vista non-elevated apps only
have standard user rights, and so they only have write-access to things in
your user profile or things that you created, and read-access is restricted
in many places.

I'm working on a program in my spare time to help alleviate this problem.

Also, if you post what you have changed your UAC settings to, that may help
me a bit :).

- JB

Vista Support FAQ

Chad Harris

From the XP Boot trying to Access Vista Folders. In a little while when I
go to do some work with Vista I'm going to list those and put them together
for you. When I've done that I appreciate your take on it.

BTW I can drag from XP to Vista now with no problems. I cannot though enter
many Vista folders from XP for example if I'm on XP and I type

and try to open E:\Users\Profile\AppData\Local\History I can get into
AppData\Local but not History or some of the folders in it.

I'm denied access to E:\Users\Profile\ApplicationData
I can't access My Pictures and probably more folders if I tried. I can
access Documents but not any individual folders in it.
I can drag from Vista to XP while on XP and move or copy.



Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

gadgets not working? 3
SendInput fails on UAC prompt 3
Disable UAC prompt for a .exe 9
UAC takes 10 seconds to show 2
Disable User Account Control (UAC) 5