Trouble with a Canoscan LIDE 70 Scanner



I have already talked to Canon Technical Support and have had no
success. I have uninstalled and reinstalled the Vista 32bit drivers for my
scanner and it is detected and device manager reports it running with no
errors. I am running Vista 32 Ultimate. The moment I go to scan anything with
it, it starts to scan, freezes, then errors out. I have tested the scanner on
a Win XP machine and it functions perfectly. I have tried several scan
programs, and the error is always the same. It just starts to scan the image
and locks up. I have to unplug the USB cable to get out of the lockup. I have
tried several USB ports. Any Vista gurus in here that might have a trick up
their sleeve that I have missed?

Hugh Wyn Griffith

then errors out.

What do the error messages say?

When you first installed the drivers (and other Canon software?) did
you do it with the scanner and its USB cable disconnected from the PC?

Note this general Cannon instruction for your model:

Do NOT connect the scanner to a computer before installing the
software. If you connect the scanner and the Found New Hardware Wizard
appears, click [Cancel].

Quit all running applications before installation, including anti-virus

For Windows 2000/XP, log in as an administrator to install the software

I've found Run as Administrator important under VISTA so if you did not
use that try it -- right mouse click on the installation file ans
select Run as Administrator.

Is the USB cable connected direct to the USB on the PC or via a hub?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question