The dreaded network share over vpn problem in vista



I have been working this one on and off for about two months now with no
clear resolution. Using Vista business to connect via VPN to a domain
network. Domain is all Server 2003 R2 SP2. I use the vista VPN client to
connect to a watchguard x700 firewall. Then i am supposedly on the network.
this setup works flawlessly for all of our XP Pro boxes. On vista i can ping
and remote desktop to anything on the network but cannot access DFS shares
via the mapped drives in My computer. Occasionally i can access the shares
via UNC navigation, but not always. Various errors occur. From the 'attempt
to compromise security' error to the 'network path not found' error. Here is
what i have tried to date.

Did net view , can see a list of all computers on the network.
did net view \\computername for the file server, sometimes all of the shares
show up, sometimes they don't.
Did net use \\computername /user:my username, recieved a 'account locked out
error. Thought that i go that one because i wasn't logged off of my desktop.
Logged off desktop and tried again. Same error.
Logged off of laptop and logged back on to refresh credentials. Problem
gets worse. No longer can see shares via net view \\computername
Disabled ipv6 for the VPN connection. No change in results.

Thought it might be the network metric bug (KB930163), Ran the hotfix, no

Wonder if some of this is how we map the drives to the shares. we use a
logon script built upon net use. Works fine when on the domain in both XP
and Vista.

Have another user with Vista Business on his laptop. Has same issue but he
says that if he stays vpn'd in for 20-30 minutes then the drives magically
start working. Network discovery is turned on for the Vista machines on the
domain. So i don't know why it would take 20-30 minutes.

I am pretty convinced that this is a bug. Some of my research indicated
that a similar issue happened with XP upon initial release. That got fixed
in SP1. I only hope that Vista SP1 fixes this one. Our firm depends heavily
on VPN since we all travel alot. Right now the problem is manageable. But
we upgrade hardware pretty aggressively. I will see more vista laptops
within the next six months to a year. I have five free upgrades sitting in
my drawer right now that I refuse to deploy until this and some other issues
are fixed.

would be nice to get a glimmer of hope from MS. I would be happy with a 'We
are aware of the problem and are working on a solution'. Dead silence is not
very comforting.


Hi Russell, we are running into the exact same issue, except our VPN is a
SonicWALL SSL VPN Connection. All the same issues you describe. My XP Pro
SP2 machine (on a virtual host on my visat machine) works fine, but all users
Vista machines do not work.

Our DFS shares are mapped using a VBS script on logon.

If anyone can provide insight on this it would be great, as we work around
it but not efficiently, thanks


I finally resolved this. Turns out the solution was simple but not obvious.
You need to map the drives using the fully qualified domain name of the
server and not just the server name. Format looks like this:

'\\\fileshares\staff' instead of

Vista uses the short name by default, so when you map the drive you need to
adjust the FQDN in the path box after you browse the location. If you map
drives via script, you have to adjust it in the script.

Hope this helps.


We found this issue as a qorkaround which corrected the issue:

under the cause we matched this: NetBIOS over TCP/IP (NetBT) is disabled on
the remote Windows Vista client.

Once we made these changes it worked, however, if you uninstall and
reinstall the vpn active x control (or IPsec client if you use that) you need
to rerun these changes.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question