System Restore Not Working/Won't Open



I have discovered my Vista (Home Premium) system restore isn't working.
After a fresh boot, when I try to open "system restore" from the start
menu... my computer seems to go nowhere. Nothing appears to happen. If I
do it a second (and on) time, I get a message that says "system restore
wizard is already running", when in fact it is not (per task manager).
Also, about an hour after the FIRST attempt to open system restore... I get a
screen that sais "no restore points have been created on your computer's
system disk..."

If I go to System Properties - System Protection tab to see if I can create
a restore point... I get a continuous "searching" in the Automatic Restore
Points section, and the "create" button is not available (not highlighted).
The "system restore" button is also unavailable (not highlighted).

Can anyone help me understand what is going on with my computer, and
hopefully help me remedy the issue. Thank you.

Rick Rogers


Most likely either the existing restore points or the index is corrupt.
Probably the easiest way to fix it is to completely disable system restore,
then reboot and restart the service. This will lose any existing points, but
they aren't working anyways at this juncture. To disable it, run 'control
system' from the start/search line, then click on the line for 'system
protection'. Uncheck any monitored volumes and then click apply. Reboot the
system and then re-enable the selected drives.

Best of Luck,

Rick Rogers, aka "Nutcase" - Microsoft MVP

Windows help -
My thoughts


Rick.. thank you for your response. When I get to the system protection
screen, I don't see any "monitored volumes" to uncheck. I have a continuous
"searching" under the available disks heading. The system restore, create,
and apply buttons are not available to use... not highlighted. Am I doing
something wrong? Any other way to access what you suggest?


Thank you Rick for your response. When I get to the System Protection
screen, all I see is a continuouse "searching" under Available Disks. I do
not see any "monitored volumes" to uncheck. Am I missing something??? The
system restore, create, and apply buttons are unavailable for use... they are
not highlighted. Any other suggestions on how access what you are
suggesting? Thank you again.


Mark... I reviewed this link closely. I am not seeing anything that I have
not already tried, is applicable to my computer, is working properly to do
try some of the "fixes", etc. Any other suggestions?

Mark L. Ferguson

I would first try SFC,
Some Windows Vista functions may not work, or Windows Vista may stop
and if no help, I would run Vista setup, and accept the offer for "repair"
after the EULA comes up.

If you have an OEM system, pressing F8 after the BIOS screen during startup
will usually offer the OEM Repair options.


You are not alone with System Restore" problems.
I have a 2 month-old pc with Vista Home premium pre-loaded (no disks, the
"recovery" is in a hidden partition which wipes C: and restores "factory"
settings - a 3 day job to fully restore all apps)
Needed, since I just had a terminal Vista crash.

Have discovered the hard way that when a restore point is automatically
created, so the earliest is deleted (so you can NEVER have an "original"
restore pont - only as far back as the last 2 software loads). Only
solution is to back up onto other media using stand-alone software.

I also have similar problems initialising "Sytem Resore" - nothing on
screen or taskbar, second attempt says "already running" .... it gets there,
eventually, just takes a lot of time.

Frankly, Vista is a pain in the butt, and should never have been released to
the "home user" market. Its primary function is as a corporate (fail-safe,
idiot-proof) OS, to justify corporate investment in IT "professionals".
IMHO, the regular home user (the vast majority of the pc market) was quite
happy with XP - far more user-friendly. The so-called Vista improvements
are far outweighed by its user unfriendliness (who but an idiot needs pop-up
screens asking to confirm they want to run a prog they consciously
FWIW - my "old" pc running XP never crashed in 4 years - I regret the
impulse to buy a new one, thanks to current Vista experience. (should have
learnt from that - IE7 was a disaster on that machine, I reverted to IE6
after 2 months frustration. Alas, no reversion possible in Vista)
One other anomoly - running IE7 in "Admin" mode yields a message "this prog
is unsigned - may be unsafe" (or words to that effect) - so, who DID write
"iexplorer.exe" if not Microsoft?


Mark... I tried the SFC and "did not find any integrety violations". I
need help/advice with the Vista Setup. I only have a reinstallation disk for
my Vista... doesn't that mean I have to totally reinstall Vista. In
essence, starting from square one and reinstalling all files and programs?
I've only had this machine/vista for 3 months and would certainly hate to
have to start over. Yikes.

Thank you!

Mark L. Ferguson

Very often, if you press F8 during the black screen of startup, ( right
after the Bios screen), you get a menu and the OEM has added a
non-destructive repair to the list. If not, and SFC failed, as well as all
the things Bert recommended, I don't see an option for you. Your OEM
expected you to backup. There was probably some warning to that effect
during initial setup.


Dave... I can understand your personal point of view on this issue. But, I
have used system restore many, many times and would feel much better having
the function up and running as it should be. Also, in this case, not having
it working has affected the way some other programs work. If a
"backup"/restore point is required, some programs/functions aren't working.
I don't understand how they are interconnected, I just know that they are not
working properly as a result of this. That is how I discovered the issue in
the first place. Thank you for your help and advice.


"Mark L. Ferguson" wrote:
Thank you Mark!!!! It's working!!!! I had previously done this awhile
back with no success (no dates even showed up). I tried it again as a last
resort. Believe it or not, to my surprise, two restore points/dates came
up. I chose the earliest (3/31) and tried to restore from that. Sadly it
failed. I then tried the most recent date of (4/1) and it was succesful.
I rebooted, made a few adjustments to my system (that I had done since
restore point), and all was fine with the world. I now have access to my
system restore and have visable restore points. I was worried with my
automatic updates last night, as I thought maybe one of the recent ones may
have caused this issue to happen. But, all 13 windows updates loaded up
successfully, and system restore is still up and running. I am a happy
camper. Thanks again.


Thank you. I don't think the time element is a factor in this. After the
first attempt to open system restore, I will eventully get a screen with a
message saying it can't open. After the successive attempts, I get the
"already running" message and then it closes. In System Protection screen,
my computer would "search" for many, many, many hours and go absolutely

When the System Protection

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question