System.DirectoryServices permissions


B

blain

I have found a couple threads that gave me information on this, but not one
that actually answered it.

I have the following situation...

We have client machines in a private network. They get a list of
applications they can run from the server and execute them from there. So in
1.1 framework configuration I have granted by URL fulltrust permission for
Server1/*

This has worked great until just recently. One of these application goes
out to Active Directory and allows the user to add/remove people from groups.

When I try to run this I now get the following error:
Request for the permission of type
'System.DirectoryServices.DirectoryServicesPermission,
System.DirectoryServices, Version = 2.0.0.0,Culture=neutral,
PublicKeyToken=b03f5f7f11d50a3a' failed

Now after reading some threads I found on this I took a copy of the .exe
file and brought it to the local machine and ran it there without an issue.

So it is definitely some sort of .net Framework security that won't let me
run this from the network drive. My problem is that copying it local to all
these client machines is not an option in this enviroment. It worked this
way before and I need to make it work this way again.

Like I said I have the server set by URL to fulltrust, I also changed the
LocalIntranet_Zone under Machine Code Groups to FullTrust and got the same
behaviour.

Could someone help me pinpoint what I need to change to get this working
again?



here are some of the threads I was going through
http://vbcity.com/forums/topic.asp?tid=125272
http://geekswithblogs.net/TimH/archive/2006/03/08/71714.asp
http://www.experts-exchange.com/Programming/Languages/.NET/Visual_Basic.NET/Q_23930277.html
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top