Stop Error - STOP: 0x0000007b(0xF7BA5528,0xc00000034,0x00000000, 0x00000000)




We've got an Adpatec Raid Controller 1210SA. I created a custom component
and imported it into the DB, and then into my SLX image. All appears fine,
I don't get an error messages at any time. Once I build my Run Time Image,
I copy that image onto a "test" hard drive that I've got, and then put that
Test hard drive into my target machine which has the Adaptec RAID card. It
boots, and FBA run fine and I'm able to log in, look in device manager and
see the Adaptec controller.

All is great at this point, so I grab a HD from one of the systems we
deploy, since my "test " hard drive is different from the ones in our
deployed machines. The Test HD is a segate and the deployed ones are a
Hitachi Deskstar. So I copy the Run time Image to the HD we have in all our
systems, take it to the target machine with the Adaptec RAID card let FBA
run and upon reboot I get the above stop error.

If I remove the RAID card out of the equation I can boot just fine, so I'm
assuming it;s the RAID driver, but it always works fine on the Segate drive
so that proves to me the RAID controller is doing it's job. I've tried
several HD of the type from our deployed machines and I always get the Stop

Anyone have an idea why one HD work fine, but the other HD does not? Same

Sean Liming \(eMVP\)

The white paper Stop 0x0000007B Error V1.2.pdf
list many of the missing components that could cause 7B, but the system
already works with the Segate drive so you don't have any missing chip
drivers. Why the Hitachi runs without the RAID is a bit interesting.

It might be that the disk driver component is correct for the Segate, but
not for the Hitachi. There are three "Disk Driver" components in the
database. TAP picked up the one that mached the hard drive through the RAID
that was in the system originaly - I assume this was the Segate - is this


Sean Liming /
XP Embedded Book Author - XP Embedded Advanced, XP Embedded Supplemental



When I ran TAP.exe the Hitachi drive was in the system, but the Adaptec Raid
controller was not. I didn't want to take he time to load XP pro, since I
knew I was going to make a component from the raid driver. I'll run TAP.exe
again,and this time I'll load Win XP pro, and have the Adaptec raid in the
system. Since a component has been made, I'll assume it'll get added to my
SLX file automatically when I run Dependence check on my image.

I'll let you know what I find out.



I thought this might be of interest to you.

I called Adaptec tech support today. Even by loading XP Pro from CD with
the Adaptec Raid controller, and going the "Press F6 to specify additional
devices" route I still got the same stop error. From the CD install I was
able to create the partition, and format the drive, so I know the Adaptec
drive was loading/working, else the install wouldn't have seen the hard

OK, so I got the blue screen with the Hitachi Drive, but the Seagate drive
was able to boot just fine, once again. The tech at Adaptec looked up the
spec on my Hitachi drive, and he said the drive was of SATA2 type, and that
Seagate drives have a jumper to go between a SATA1 or a SATA2. Apparently
this one is set for SATA1 by default.

The current Adaptec RAID controller is for drives of only SATA1, which may
be why my Hitachi drives wont work. I don't know that much about SATA
drives, but it sounds believable to me, how about you?. He gave me a model
number of a PCI RAID driver that is of TYPE 2 so until our OEM can get that
to me, I won't know for sure. I'd think this is something our PC supplier
should have be able to figure out, instead of me spending time to
troubleshoot this.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question