Star Force Protection


G

Guest

I can't get any of my games that use the star-force disc protection to play.
After the game is installed you have to reboot your pc to finish the
installation of the starforce driver. When vista loads you get a screen
saying that vista could not load the driver. You get the same message when
trying to start the game.

Any work arounds for this yet?

Games I have that use star force:
GT Legends
Lock On
 
Ad

Advertisements

G

Graham Wilmott

Are you running on 64-bit or 32-bit?

If 64-bit, you may need to disable the check for signed drivers before the
star force driver can run...
 
G

Guest

I'm running the 32bit vista version.
I read on extremetech.com that they could not get around this issue.

MySpecs
asus pc800 deluxe MB
Intel P4 HT 800FSB 2.4Ghz
Corsair XMS 2Gig
ATI x700 256mb
Raptor 10,000 rpm HD
 
Z

Zack Uribe

It is a known issue with StarForce and Vista. This is an excerpt from the
ExtremeTech report: Will Vista run your games?

Splinter Cell: Chaos Theory
The latest stealth action thriller from Ubisoft doesn't work in Vista, but
it's probably not any fault of the application itself – it's the StarForce
copy protection. StarForce installs a low-level (ring 0) driver to access
your optical drive, and this driver has not been Vista certified. So
Splinter Cell: Chaos Theory asks you to reboot after installing, which you
do, and then upon reboot Vista informs you that it won't load the driver due
to "compatibility problems." The 32-bit version of Vista will allow unsigned
kernel-level drivers if installed from an account with admin privileges --
as ours was. We were unable to find any sort of workaround or Vista-ready
driver on the StarForce site.

What's worse, the StarForce driver will try (and fail) to load every time
you reboot, even if you uninstall the game, and the removal tool doesn't
work properly by default. It doesn't give you any indication that it didn't
work, however. You have to run it as an administrator by accessing the
Compatibility tab in the removal tool's Properties menu. Visually, it looks
like it's doing the same thing as when you don't run it as an admin, but it
will at least get StarForce off your system.
 
G

Guest

Update On the StarForce Patch.

After installing the patch for starforce's website I was able to boot up
vista and the starforce driver without any problems. BUT, when I try to
launch a starforce application my system freezes.

I've tried running the app as xp compatible, run as admin, nothing seems to
work. It always freezes the computer requiring a cold boot. So as for now
starforce is a vista no-no it seems.

Anyone got SF games to run yet?
 
Ad

Advertisements

G

Guest

I downloaded the patch from StarForce and installed it. It works. I can
play Lock-On, and Splinter Cell: Chaos Theory.

I am using P4 820 "D" 2.0 GB RAM, ATI X850XT, Benq DVD-RW "Lightscribe", and
other hardware.
 
P

Pufnstuf

im having the same problems, i am trying to install the game prince of
persia the two thrones. and i can't run it because starforce is
incompatible with my computer.

i checked the link you gave out but when i clicked it an error (404-
HTML not found) occured. can someone help me please.

I believe you install the game and then update the Starforce driver to be
compatible with Vista before you run the game. Starforce doesn't get
installed until you first run the game when it asks you to reboot the PC.
Now that you tried to run it Starforce has already tried to install.
Starforce has a Starforce driver remover tool at their website. Get that
and run it to unintall the Starforce driver and then get the Vista
compatible version from them and install that.
 
Ad

Advertisements

A

Andrew Rybenkov

then get the Vista
compatible version from them and install that.

or better spend 2 minutes searching in Google no_cd version.
Upgrading of crapware is nonsence.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top