SiS 661FX chipset with NVIDIA video cards under Vista


G

Guest

I have a SiS 661FX AGP motherboard with an Nvidia GeForce 7600 GT video card
and under windows vista all games including the built in card games
(solitaire etc) have severe graphical corruption and artifacts.. I tried an
older GeForce 6600 GT video card and the same problem exists.. Ive narrowed
it down to the SiS AGP driver, If I install the Windows 2000/XP version of
the driver under Vista all problems are gone except new problems arise - I
cant see any picture just a green screen when watching TV under Media Centre
also certain video files play back severly corrupted or rainbow coloured.
Under XP everything works perfectly. I have searched the internet and found a
number of people have the exact same problem as me. Will SiS or Microsoft
ever bring out working SiS AGP driver for 661FX chipsets or am I stuck with
an unusable Windows Vista where I either have to buy a new motherboard or go
back to Windows XP?
 
Ad

Advertisements

R

Rock

Sniper82 said:
I have a SiS 661FX AGP motherboard with an Nvidia GeForce 7600 GT video
card
and under windows vista all games including the built in card games
(solitaire etc) have severe graphical corruption and artifacts.. I tried
an
older GeForce 6600 GT video card and the same problem exists.. Ive
narrowed
it down to the SiS AGP driver, If I install the Windows 2000/XP version of
the driver under Vista all problems are gone except new problems arise - I
cant see any picture just a green screen when watching TV under Media
Centre
also certain video files play back severly corrupted or rainbow coloured.
Under XP everything works perfectly. I have searched the internet and
found a
number of people have the exact same problem as me. Will SiS or Microsoft
ever bring out working SiS AGP driver for 661FX chipsets or am I stuck
with
an unusable Windows Vista where I either have to buy a new motherboard or
go
back to Windows XP?

Microsoft doesn't write the drivers. It's up to SiS. Have you contacted
them?
 
G

Guest

SiS are not able to be contacted because they don't sell products straight to
the end user.. I have contacted Gigabyte twice the motherboard manufacturer
and they can't give me an answer.
 
G

Guest

Well I bit the bullet and bought a new motherboard with an Intel chipset and
lo and behold Vista works perfectly on this system.
 
Ad

Advertisements

R

Rock

Sniper82 said:
Well I bit the bullet and bought a new motherboard with an Intel chipset
and
lo and behold Vista works perfectly on this system.

Great, glad it's working for you know. Thanks for posting back the
resolution. Definitely was a hardware/driver problem.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top