Send Object not working


A

AlCamp

On an Access97 form, on an OnClick event I initiate a...
DoCmd.SendObject acSendReport, "rptMyReport"

The procedure fails with...
RunTime error 2046
The Command or Action 'Send Object' is'nt available now.

I know I've used SendObject successfully in the past... I've even answered
some posts here regarding the SendObject function.

I checked my references, the .mdb is not ReadOnly, although I always use
module code the SendObject Action does display in the Macro command list,
and I tried the MSKB on "Error 2046" "Send Object not available" etc...
etc.. with no luck.

Really weird... is this a known bug/problem? Never have seen it on these
NGs, and I'm very surpised I didn't find more on this on the web.

Any help greatly appreciated...
Thanks,
Al Camp
 
Ad

Advertisements

A

AlCamp

Problem solved!
I had removed Outlook when I had first installed my system and used just OE
for my Email and NG work.
I re-installed it, and that fixed the File/Send and SendObject problem.
Al Camp
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

SendObject fails 1
access 2000 sp3 - sendobject fails 4
Form Size 2
SendObject error 2046 2
Runtime error 2046! 1
Strange problems with SendObject 11
Run-time 2
Email from form, button error 3

Top