Security Centre saying Defender is OFF and no antivirus



Hi all,

I'm suffering from what seems to be a common problem, but none of the
standard fixes are working. I'm working under Vista Ultimate (32bit).

Security Centre is incorrectly reporting the Defender is off, and no
antivirus is installed. In fact Defender is running, and Avast Antivirus is

Apparently this has something to do with the WMI repository, but I can't get
the repository to rebuild. I've tried shutting down the MSI service and
removing the repository folder, and restarting the service and rebooting does
not rebuild the folder.

Equally, on a command prompt (run as admin) the winmgmt /verifyrepository
and winmgmt /salvagerepository do not run even after lots of attempts. The
commands both return the folowing error: "WMI repository verification
failed. Error Code: 0*8004100A"

Does anyone have any ideas? The whole system has been fine until today when
this problem has suddenly arisen.



Martin Harris

Hi again.

Don't worry about this one - I've fixed it. It involved using WMIdiag (a
tool downloaded from Microsofts download centre) and clearing a number of
errors that it raised. Eventually the Repository reappeared and all has
been fine since.



Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question