Save RDP Settings - Prompts for Password



The RDP File looses/Prompts for the password.

I have an unattended build that autolog's on and launches an RDP
session to a W2K SP4 fully patched server. The RDP-Tcp config is:

Use client-provided logon information - CHECKED
Always prompt for password. - UN-CHECKED

The client is XP SP2, fully patched. When I save the settings file and
launch it on the same PC with the same USER ID it works fine. If I
copy it to a different machine, it prompts for the password on the
connection to the server. I tried changing the security on the file
for Everyone Full control before coping it off and onto the new XP
workstation. That did not work.

This is the only function of the box, KIOSK.

I tried the autordp.exe and that works fine; however, when the
connection to the server is disconnected it leaves the MSTSC box
running open to the options. I check the process every 30sec and
reconnect to the server based on the MSTSC.exe and this technique leave
that running, and the open dialog box. Not user friendly or

It seem like there this is a common problem with no resolution.

Vera Noest [MVP]

This is by design. For security reasons, the password is encrypted
in such a way that only the same user, on the same machine, can
decrypt it.

If all users are using the same account and password, you can set
the username and password in the Terminal Services Configuration

Vera Noest
MCSE, CCEA, Microsoft MVP - Terminal Server
TS troubleshooting:
___ please respond in newsgroup, NOT by private email ___

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question