Running script with Microsoft Antispyware Beta active



I use a simple batch file to open some programs when I start to work.
However, Microsoft Antispyware Beta keeps prompting me that a script is
running. I keep clicking the "Allow" choice in the dialog box, but the
dialog box keeps popping up. The only way to get around this is to disable
Microsoft Antispyware Beta before I run the batch file. Is there any other
way to get Microsoft Antispyware Beta to allow the batch file to run


Hi Mike

When The Pop Up is displayed saying it needs your approval to run the script
make sure the box under Allow "Remember This Action" is also checked, Then
when you press allow it shouldnt give you the pop up next time its run unless
the name of the batch script is changed.

Let us if you have problems



Thanks for your prompt answer. Unfortunately, I did already do what you
recommend. I checked the "Remember This Action" box under the Allow choice,
but the warning box kept popping up. I hope you can solve this problem. The
software is really easy to use and works like a charm.


Hi Andy;
Any chace this could be a registry RunOnce problem? I have the same sort of
thing with an internet accelerator that gets "installed" at each dial-up
connection. Not enough of a registry guy to know for sure, but it's
described in MSAS Help:
Application Agent: Startup Registry Files
I've gotten sort of used to it by now, but it would be great to know how to
eliminate it after I get bored with the notification.


Hey Mike

Sorry for the delay Ive just seen your reply :)

It's hard to know why your Antispy is working in a different way than mine,
I run batch scripts quite often and although they get blocked the first time
I then don't receive any notice the next time its run once Ive clicked on
allow, It will display a new notice if I rename the batch script or If I move
it to a different location but not if its the same name running from the same

I'm just trying different ways but I cannot get it to block the script from
running more than once, if I choose allow even without checking remember this
action it will still allow it to run the next time, If I choose block then
the orange pop up appears the second time saying the batch script has been
denied permission then I have to remove it from Manage Blocked Scripts to get
it to run.

Going into the Options menu then settings and RealTime Protection gives the
option to Block all scripts but on mine it doesnt do anything, If I set it to
Block All scripts Im still able to run Batch scripts and Reg files, I even
changed the setting on the General tab to Novice user but that doesnt effect
me running batch scripts either,

Maybe worth Opening MSAS and going to Tools > Real Time Protection > View
All Security Agents , Check this page for the blocking of your batch script
and check if it shows the same script running from the same location as being
blocked on mine they are all for different named scripts.

The other option is to try a repair using the add/remove screen entry,
(Start Menu > Control Panel > Add/Remove Programs) Click Microsoft
Antispyware and then you will see the line "Click Here For More Information"
, click this then choose repair and let it finish reinstalling. Try the
scripts again and repost if it continues

Thanks Andy


Hi Dave

If Mike has it set to automatically run the script when he starts the pc
then this is maybe why its acting in a different way, if Mike says that is
how he starts the script I can check if there is anyway to avoid the constant

With your Internet Accelerator that sounds very annoying :) If they install
it at each dial up why dont they just install in once and have it under the
Run key so its always running when the system starts, Being under the RunOnce
key isnt much use to you as it deletes the registry entry when the system
reboots so its hard to know how to avoid the detections by MSAS for a new
startup entry each time it gets added, I don't think it would block it with
you already allowing it unless its a different name but it will still give
you a notice that the change has been allowed.

It might be worth contacting your ISP and asking if there is a alternative
way to do this such as installing the internet accelerator on your system
then disabling the one that gets added each time you dial out. I'm not sure
if thats possible but its sounds better than having one installed everytime
you use your pc then it deleting its run key when you reboot and then having
to get a new one installed.


Dave M

Right Andy, it only is the notification message at this point, the accelerator
is being allowed. Thanks for your comments, I'll bring it to the attention of
my ISP, maybe they never bumped into MSAS before, though I supposed it was their
way of automating updates.

Bill Sanderson

I would recommend that you find the checkpoint that monitors scripts, in
Microsoft Antispyware, and disable it, if you regularly run scripts. This
isn't a great solution, but there are some substantial bugs there--on the
first run of a script--the one where you get prompted--the folder context is
not preserved for the script--it changes to \system32.

One other thing you may be seeing--if other settings choices--or prompt
responses you make--are not being recorded or remembered by Microsoft
Antispyware, you may have a corrupted install of some sort. I'd uninstall,
delete the \program files\Microsoft Antispyware folder, and subfolders, and
reinstall. You lose quarantined items, history, and custom settings.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question