RUNAS Command and XP Themes


M

MT

Hi folks:

This isn't a life or death matter by any means, but I've got a strange
behavior under WinXP that I can't figure out or understand. I
normally am logged on as an administrator (this is a home machine).
However, I've used a version of RUNAS that allows the password to be
saved in the .cmd file to run Internet Explorer and Outlook with a
Userid that's not part of the Administrator's group, in order to
minimize my exposure to viruses, buffer overrun exploits, etc.

This all works fine, but the strange thing is that when I'm running
these applications they don't pick up the XP theme look (e.g. colors,
button shapes, etc.), and instead they look like they would when
running under Win2K. I've played with the /env and /profile options
under the RUNAS, and they don't help (in fact using /env causes the
applications not to run period). However, if I add this UserID to the
Administrators group then the applications pick up the XP theme and
look normal.

In an effort to try to find out what's going on I tried actually
logging on to the non-admin Userid by using the Switch User option,
and when I'm actually logged on to the non Administrative Userid
desktop then the applications all pick up the theme. When I'm on that
desktop and I use RUNAS to run something on an account that is part of
the Administrators group (my original account), it also picks up the
theme. However, if I run a second non Administrators group ID from
this desktop, it does not pick up the theme.

The net result seems to be that if you are running on an account that
isn't part of the Administrators group, you must be ID logged on to
the desktop in order to pick up the XP theme. However, if you use
RUNAS to run something under an ID that's part of the Administrators
group, the application picks up the XP theme regardless of what ID is
logged on to the desktop.

Anyone have any ideas why this is so, or how to fix it?


Thanks,

SW
 
Ad

Advertisements

J

Jeff Qiu [MSFT]

Hi MT,

Thanks for posting!

My name is Jeff and I understand your issue to be:
A RUNAS command issue with Windows XP Themes.

If I have misunderstood your issue please let me know.

Based on your description, I have reproduced this issue even using the
built-in RUNAS in Windows XP.

Created a test normal user.
Use the following command line under an admin log on:
runas /env /user:workgroup\test "notepad.exe"
It started using the classical style.

At first, I believe this issue is caused by the user rights.

Thus, I go ahead to test the following steps:

Use Regedit to add the permission for each root node. Grant full access to
that test normal user.

I hope to find a certain registry node that controls this theme issue
during the runas. That will explain this behavior quite good.

Unfortunately, I failed. I have added that user full access to all the
root nodes and the runas remains the same action.

BTW, I also need to point out that this test is running on a FAT32
partition. Any user has full access to file system.

Thus, I believe this issue needs further research such as a live debug to
find our what's the difference between a normal user and an admin user.

Due to the complexity of this issue we are unable to assist with this
request in the newsgroups. A suggestion would be to contact Microsoft
Product Support Services via telephone so that a dedicated Support
Professional can assist with your request.

Please be advised that contacting phone support will be a charged call.
However, if this comes out to be a bug of Windows XP then charges are
usually refunded or waived.

To obtain the phone numbers for specific technology request please take a
look at the web site listed below.

http://support.microsoft.com/default.aspx?scid=fh;EN-US;PHONENUMBERS

If you are outside the US please see http://support.microsoft.com for
regional support phone numbers.

Hope it helps!

Have a nice day!

Best Regards,

Jeff Qiu
Microsoft Online Partner Support
MCSE 2000, MCDBA, MCSA
Get Secure! - www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

--------------------
 
M

MT

Jeff:


You've understood the problem exactly right. You did the same steps
that I was thinking about doing (giving the non-admin user full
registry authority to see if some part of the theme process mistakenly
wants update authority to part of the registry). My installation is
on a NFTS partition, so your idea of running the test on a FAT32
partition to see if it was a file permission issue was a good idea as
well. I checked out the phone numbers for Microsoft support, and
they want $99 for a call. I'm not sure I want to risk that amount of
money to have them work on what's admittedly not a life or death
problem, but just one of XP's minor annoyances. Since you appear to
either be a MS employee, or have some connection to them, is there
anyway you can submit the problem through some other channel? Since
you've been able to reproduce the problem yourself and you don't see
anything obvious I missed, then would they accept it from you as a
genuine issue without requiring a $99 up front fee?

Also, when searching the knowledge base I came across an article that
discussed the fact that if you open a cmd prompt box the theme isn't
applied to the box, and the answer was that this behavior was by
design. This occurs on a regular cmd prompt, not just one opened by
using RUNAS. I'm wondering if there is some connection.

Thanks for your assistance.


MT
 
Ad

Advertisements

J

Jeff Qiu [MSFT]

Hi MT,

Would you please give me your correct e-mail that I can reach?

Thanks!

Best Regards,

Jeff Qiu
Microsoft Online Partner Support
MCSE 2000, MCDBA, MCSA
Get Secure! - www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

--------------------
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

RUNAS Command 1
Runas command 5
RUNAS command 2
RunAS Command & Limited Accounts 6
RUNAS with XP SP2 0
Erroneus 1326 error with runas command 0
Runas 2
runas 0

Top