RIS: PXE install not working


J

Javier

Good morning all,

I've implemented RIS a couple of days ago on a network of
60 users. It appears that while floppy installation is
working fine PXE is not working at all. I've checked DNS,
DHCP and RIS settings and all is good. I've tried
different systems with different versions of PXE but I'm
getting the same error.

PXE-E53: No boot filename received

Doing a search on internet I've found people having errors
like TFTP failed and a work-around but this is not it. Any
ideas?

Help is appreciated.

Thanks
 
Ad

Advertisements

B

Bill Curtis [MSFT]

From Intel's web site:

PXE-E53: No boot filename received. The Boot Agent received a DHCP or BOOTP
offer, but has not received a valid filename to download. If you are using
PXE, please check your PXE and BINL configuration. If using BOOTP, be sure
that the TFTP service is running and that the specific path and filename
are correct.

Basically, we see this error a lot due to the following:

1. Multihomed RIS server
2. A remote access card (iLo/DRAC) installed usually takes an IP Address -
this would count as being multi-homed
3. The BINL service needs the following in order to operate in a
multi-homed system:

(1) DHCP to be installed on the same server
(2) a scope activated for each NIC on the machine
(3) each NIC be authorized, regardless of subnet


4. Problems discussed in the following article:

259670 Using Dynamic Host Configuration Protocol Options 60, 66, 67 to
Direct
http://support.microsoft.com/?id=259670


I would try the above first. However, I find that it is a lot easier to get
a network trace of a failure between the PXE client and the Server to
figure out exactly what is going on. You may want to contact PSS support
for troubleshooting and analysis.

- Bill Curtis [MSFT]
“This posting is provided "AS IS" with no warranties, and confers no
rights.”
 
G

Guest

Hi, thanks for that piece of information. I've checked the
TFTP system and it's working fine. But it must be
something because I am reading true enough that the system
is not able to get a boot image. I'm changing different
DHCP setting related to that but no joy. This system is
not multihomed in any way.

Thanks,

Javier
 
B

Bill Curtis [MSFT]

Where is the DHCP server located? Is it on the same box as RIS? Also, are
you on the same subnet?

- Bill Curtis [MSFT]
“This posting is provided "AS IS" with no warranties, and confers no
rights.”
 
L

Lars

Is it an Intel Network card that you are using? I am
having the same problem but only with PCs that have Intel
nics. My Realtek and Broadcom NICed PCs work just fine.
Odd thing is just 2 weeks ago the Intel nics worked, I
actually was able to load images on them, then it stopped
after putting some Microsoft updates on them and the
server had some data issues.

If I use option 67 in DHCP it will show that it gets an IP
but still doesn't see the bootfile.

My problem may be way off from yours though. If RIS and
DHCP aren't on the same PC, make sure you have help IPs
for your RIS setup on your routers, I ran into that
problem when setting mine up.

Lars
 
Ad

Advertisements

L

Lars

Nevermind, figured it out after turning on logging. For
some reason it was seeing them as unknown clients and not
letting them boot. I set up another RIS server to take the
first ones place and after getting it work the first one
started working again. HUH? Anyway got both of them
working now and it loads into PE 1.2 with no problems now
that the winbom.ini file is in the right folder (i386
\system32).
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top