RID Pool Error


D

Durga Rao

Hi Friends,

In my network previously one NT-Domain(4.0) is available I down this DC and
installed WIN2K Advanced Server and created Active directory in this
server. I am not using the NT Domain. I used the DCDIAG /V /C /E command
the out-put shows " Found 2 DC(s) Testing 2 of them" Win2k Server is passed
the test but another DC LDAP failed with error 58, and RidManager test is
giving warning There is less than 0% available RIDs in the current pool. In
Active Directory Users and Computers -> Operation Master RID tab shows
operation master is present 2k domain only. I started NT domain after the
above test in NT event log I found error event 3216 with error 67.
please help me.

Regards
Durga Rao N.
 
Ad

Advertisements

A

Ace Fekay [MVP]

In
Durga Rao said:
Hi Friends,

In my network previously one NT-Domain(4.0) is available I down this
DC and installed WIN2K Advanced Server and created Active directory
in this server. I am not using the NT Domain. I used the DCDIAG /V /C
/E command the out-put shows " Found 2 DC(s) Testing 2 of them"
Win2k Server is passed the test but another DC LDAP failed with
error 58, and RidManager test is giving warning There is less than 0%
available RIDs in the current pool. In Active Directory Users and
Computers -> Operation Master RID tab shows operation master is
present 2k domain only. I started NT domain after the above test in
NT event log I found error event 3216 with error 67.
please help me.

Regards
Durga Rao N.

Event ID 3216 with System Error 67 indicates it cannot find the other DC.
Here's what that error means:
"Event ID 3216 System Error 67: Replication fails and the following event
is logged: Event ID 3216 Source: Replicator System error 67 has occurred
Specify the name of the Import/Export servers in the To/From list within the
Directory Replication properties."

That tells me you may have misconfigured DNS or misnamed the domain. The
FIRST thing I would do is make sure in IP properties, that the DCs are the
ONLY DNS servers listed in there. You can't have an ISP's DNS in there or it
will ask your ISP's DNS, "Where is my domain controller?" Your ISP does not
have that information. P{oint only to the internal DNS and configure a
Forwarder to your ISP's DNS. Since this is Win2000, see this article on how
to configure a forwarder:
http://support.microsoft.com/?id=300202

If the domain DNS name is a single label name, that will cause this as well.
Example: "domain" instead of the proper "domain.com", "domain.local" or even
"domain.durga". That is much more difficult to fix, depending on the
domain's functional level.

Here's a list of reasons why this can be happening:
1. Single label name.
2. SRV records missing.
3. Disjointed namespace.- AD domain name doesn't match the Primary DNS
Suffix and/or the zone name.
4. Using an ISP's DNS in IP properties of the DC and clients.
5. DHCP Client service disabled.
6. DC is multihomed
7. 3rd party firewalls
8. etc....


If you like to get specific help to diagnose this issue, for starters,
please post the following information:
1. Unedited ipconfig /all from one of your DCs, the machine you're trying to
promote, and one of your clients..
2. The exact zone name spellng in DNS and whether updates are allowed on the
zone.
3. The AD DNS domain name as it shows up in ADUC.
4. If the SRV records exist under your zone.
5. Any errors in the Event logs on the DC under System, Replication Service
and Directory Services (post the Event ID# and source please)
6. Dcdiag /v /fix > c:\dcdiag.txt (post the dcdiag.txt as an attachment)
7. Netdiag /v /fix > c:\netdiag.txt (post the dcdiag.txt as an attachment)
8. More than one subnet?
9. Forwarder(s) configured?


Here's more info on AD and DNS (It's nothing like NT4):

825036 - Best practices for DNS client settings in Windows 2000 Server and
in Windows Server 2003:
http://support.microsoft.com/?id=825036

291382 - Frequently asked questions about Windows 2000 DNS and Windows
Server 2003 DNS
http://support.microsoft.com/default.aspx?scid=kb;en-us;291382


--
Ace

This posting is provided "AS-IS" with no warranties or guarantees and
confers no rights.

Having difficulty reading or finding responses to your post?
Instead of the website you're using, I suggest to use OEx (Outlook Express
or any other newsreader), and configure a news account, pointing to
news.microsoft.com. This is a direct link to the Microsoft Public
Newsgroups. It is FREE and requires NO ISP's Usenet account. OEx allows you
to easily find, track threads, cross-post, sort by date, poster's name,
watched threads or subject.

It's easy:
How to Configure OEx for Internet News
http://support.microsoft.com/?id=171164

Ace Fekay, MCSE 2003 & 2000, MCSA 2003 & 2000, MCSE+I, MCT, MVP
Microsoft MVP - Directory Services
Microsoft Certified Trainer
Assimilation Imminent. Resistance is Futile
Infinite Diversities in Infinite Combinations

"Very funny Scotty. Now, beam down my clothes."

The only thing in life is change. Anything more is a blackhole consuming
unnecessary energy.
 
Ad

Advertisements

A

Ace Fekay [MVP]

In
Durga Rao said:
Hi Ace Fekay

Thank You very much for your replay.

I am attached diag.zip file its contains DCDIAG.TXT, IPCONFIG.TXT,
NETDIAG.TXT files please check these
and give me a solution.


Thanking You
Regards
Durga Rao N

Thank you for posting your config info.

First thing I see is you have a multihomed (multiple NICs) domain
controller. This is HIGHLY NOT recommended because it causes numerous Active
Directory problems.

The other issue I see is you are using the localhost IP address as the DNS
address. This is not recommended either because of other minor problems. I
would suggest both interfaces only point to the IP address of the internal
interface on the machine, which I'm not sure which one it is in your case
because neither have a gateway address. Usually the one without the gateway
is the internal one. You will need to decide that.

Also, I assume you have a zone name created on your DNS server (which is
this server called "server2k.svecw.svecw.com") that is allowing updates
called "svecw.svecw.com".

From what I see, the domain controller can't see to "find" itself in DNS
when it queries for itself. That's how AD works. It uses DNS to store
service location records (SRV records) so any machine in a domain can find
an AD service when it needs it (like when it needs to login, authenitcate
for resourece access, grab a new RID for a new object you are trying to
create, etc).

The easy method to fix is disable one of the NICs, If you will go with this
method, you will need to figure out which network you want it on, and
provide the gateway address to access the other network and for others on
that network to access this domain controller. Once you've made the above
changes, please run these commands:

ipconfig /registerdns
net stop netlogon
net start netlogon

Then check and make sure the SRV records showed up in the zone (those
folders with the underscores in their names). Delete any reference to the IP
address you did not want under the zone and under the _msdcs.gc zone.

The other way, (the MORE DIFFICULT method) if you want to keep both
interface operational, there are a series of steps to confiure it to work.
Below I posted the necessary steps to FORCE a multihomed domain controller
to work properly and get rid of this problem. It's alot of work and is is
based on altering default domain controller functionality to make this work
(which I normally do not like to do).

After you've made the changes below, if you are going to follow this method,
run these commands please:

ipconfig /registerdns
net stop netlogon
net start netlogon

Then check and make sure the SRV records showed up in the zone (those
folders with the underscores in their names).

\Good luck!

=======================================
A multihomed DC will do this all the time. You would be surprised. If you
search back thru the groups and look for any references to multihomed DCs or
multi NICs, etc, you can see dealing with a multihomed DCs is a PITA.

Suggestion: Disable one of the NICs, preferrably the "external" one. You
have a 10.x.x.x range and a 192.168.x.x range. I see the DNS settings are
using the 192.168.x.x range. Is this the internal private default network?
If so, I would disable the 10.x.x.x NIC, and delete the references to the
10.x.x.x IP address in the zone for the Host record and for the (same as
parent) record, and the _msdcs.gc record as well. That is what's causing the
difficulty.

If you disable them, then you should be fine. Let the network route the
traffic or get an inexpensive router to handle it internally, of course with
setting the appropriate static routes if needed.

If you do not want to disable them, here's how to insure that one of those
NICs DO NOT register into DNS to alleviate this problem. You NEED to stop
registration on one of them. However, if you have clients from both sides of
the fence authenticating, that can be difficult, and my suggestion is back
to disabling one of them and use a router. If you want to use a Windows
machine (non-DC) as a router, go ahead, but that's kind of an expensive
alternative.

Here are the steps if you want to keep both, but like I said, it's way
easier to get that router...

I also provided some links ebelow xplaining what's going on and where some
of these reg entries came from and what they do. YOu can ignore the blurb in
the beginning, if you like...

********************************
Multihomed DCs, DNS, RRAS servers.
+++++++++++++++++++++++++++++++++++++++++++++++++++++++
+++++++++++++++++++++++++++++++++++++++++++++++++++++++
Below are the manual steps in more detail, which I had outlined in the above
paragraph:

Honestly, multi-homed DCs are not recommended because of the associated
issues that can occur, as you've encountered. We usually recommend
purchasing an inexpensive Linksys, DLink, etc, Cable/DSL router to perform
NAT for you, take out the extra NIC off the DC, but still let the DC handle
DHCP (and not the router).

Little background on AD and DNS:
First, just to get this out of the way, if you have your ISP's DNS addresses
in your IP configuration (DCs and clients), they need to be REMOVED.

If the ISP's DNS is in there, this will cause additional problems.

Also, AD registers certain records in DNS in the form of SRV records that
signify AD's resource and service locations. When there are multiple NICs,
each NIC registers. IF a client, or another DC queries DNS for this DC, it
may get the wrong record. One factor controlling this is Round Robin. If a
DC or client on another subnet that the DC is not configured on queries for
it, Round Robin will kick in offering one or the other. If the wrong one
gets offered, it may not have a route to it. On the other hand, Subnetmask
Priortization will ensure a querying client will get an IP that corresponds
to the subnet it's on, which will work. To insure everything works, stick
with one NIC.

Since this DC is multi-homed, it requires additional configuration to
prevent the public interface addresses from being registered in DNS. This
creates a problem for internal clients locating AD to authenticate and find
other services and resources such as the Global Catalog, file sharing and
the SYSVOL DFS share and can cause GPO errors with Userenv 1000 events to be
logged, authenticating to shares and printers, logging on takes forever,
among numerous other issues.

But if you like, there are some registry changes to eliminate the
registration of the external NIC. Here's the whole list of manual steps to
follow.

But believe me, it's much easier to just get a separate NAT device or
multihome a non-DC then having to alter the DC. - Good luck!

1. Insure that all the NICS only point to your internal DNS server(s) only
and none others, such as your ISP's DNS servers' IP addresses.

2. In Network & Dialup properties, Advanced Menu item, Advanced Settings,
move the internal NIC (the network that AD is on) to the top of the binding
order (top of the list).

3. Disable the ability for the outer NIC to register. The procedure, as
mentioned, involves identifying the outer NIC's GUID number. This link will
show you how:
246804 - How to Enable-Disable Windows 2000 Dynamic DNS Registrations (per
NIC too):
http://support.microsoft.com/?id=246804

4. Disable NetBIOS on the outside NIC. That is performed by choosing to
disable NetBIOS in IP Properties, Advanced, and you will find that under the
"WINS" tab. You may want to look at step #3 in the article to show you how
to disable NetBIOS on the RRAS interfaces if this is a RRAS server.
296379 - How to Disable NetBIOS on an Incoming Remote Access Interface
[Registry Entry]:
http://support.microsoft.com/?id=296379

Note: A standard Windows service, called the "Browser service", provides the
list of machines, workgroup and domain names that you see in "My Network
Places" (or the legacy term "Network Neighborhood"). The Browser service
relies on the NetBIOS service. One major requirement of NetBIOS service is a
machine can only have one name to one IP address. It's sort of a
fingerprint. You can't have two brothers named Darrell. A multihomed machine
will cause duplicate name errors on itself because Windows sees itself with
the same name in the Browse List (My Network Places), but with different
IPs. You can only have one, hence the error generated.

5. Disable the "File and Print Service" and disable the "MS Client Service"
on the outer NIC. That is done in NIC properties by unchecking the
respective service under the general properties page. If you need these
services on the outside NIC (which is unlikely), which allow other machines
to connect to your machine for accessing resource on your machine (shared
folders, printers, etc.), then you will probably need to keep them enabled.

6. Uncheck "Register this connection" under IP properties, Advanced
settings, "DNS" tab.

7. Delete the outer NIC IP address, disable Netlogon registration, and
manually create the required records

a. In DNS under the zone name, (your DNS domain name), delete the outer
NIC's
IP references for the "LdapIpAddress". If this is a GC, you will need to
delete the GC IP record as well (the "GcIpAddress"). To do that, in the DNS
console, under the zone name, you will see the _msdcs folder. Under that,
you will see the _gc folder. To the right, you will see the IP address
referencing the GC address. That is called the GcIpAddress. Delete the IP
addresses referencing the outer NIC.

i. To stop these two records from registering that information, use the
steps provided in the links below:
Private Network Interfaces on a Domain Controller Are Registered in
DNShttp://support.microsoft.com/?id=295328

ii. The one section of the article that disables these records is done with
this registry entry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters
(Create this Multi-String Value under it):
Registry value: DnsAvoidRegisterRecords
Data type: REG_MULTI_SZ
Values: LdapIpAddress
GcIpAddress

iii. Here is more information on these and other Netlogon Service records:
Restrict the DNS SRV resource records updated by the Netlogon service
[including GC]:
http://www.microsoft.com/technet/tr...proddocs/standard/sag_dns_pro_no_rr_in_ad.asp

b. Then you will need to manually create these two records in DNS with the
IP addresses that you need for the DC. To create the

LdapIpAddress, create a new host under the domain, but leave the "hostname"
field blank, and provide the internal IP of the DC, which results in a

record that looks like:
(same as parent) A 192.168.5.200 (192.168.5.200 is used for illustrative
purposes)

i. You need to also manually create the GcIpAddress as well, if this is a
GC. That would be under the _msdcs._gc SRV record under the zone. It is
created in the same fashion as the LdapIpAddress mentioned above.

8. In the DNS console, right click the server name, choose properties, then
under the "Interfaces" tab, force it only to listen to the internal NIC's IP
address, and not the IP address of the outer NIC.

9. Since this is also a DNS server, the IPs from all NICs will register,
even if you tell it not to in the NIC properties. See this to show you how
to stop that behavior (this procedure is for Windows 2000, but will also
work for Windows 2003):
275554 - The Host's A Record Is Registered in DNS After You Choose Not to
Register the Connection's Address:
http://support.microsoft.com/?id=275554

10. If you haven't done so, configure a forwarder. You can use 4.2.2.2 if
not sure which DNS to forward to until you've got the DNS address of your
ISP. How to set a forwarder?
Depending on your operating system,choose one of the following articles:

300202 - HOW TO: Configure DNS for Internet Access in Windows 2000
http://support.microsoft.com/?id=300202&FR=1

323380 - HOW TO: Configure DNS for Internet Access in Windows Server 2003
(How to configure a forwarder):
http://support.microsoft.com/d/id?=323380


<==*** Some additional reading ***==>
More links to read up and understand what is going on:

292822 - Name Resolution and Connectivity Issues on Windows 2000 Domain
Controller with Routing and Remote Access and DNS Insta {DNS and RRAS and
unwanted IPs registering]:
http://support.microsoft.com/?id=292822

246804 - How to enable or disable DNS updates in Windows 2000 and in Windows
Server 2003
http://support.microsoft.com/?id=246804

295328 - Private Network Interfaces on a Domain Controller Are Registered in
DNS
[also shows DnsAvoidRegisterRecords LdapIpAddress to avoid reg sameasparent
private IP]:
http://support.microsoft.com/?id=295328

306602 - How to Optimize the Location of a DC or GC That Resides Outside of
a Client's
Site [Includes info LdapIpAddress and GcIpAddress information and the SRV
mnemonic values]:
http://support.microsoft.com/?id=306602

825036 - Best practices for DNS client settings in Windows 2000 Server and
in Windows Server 2003 (including how-to configure a forwarder):
http://support.microsoft.com/default.aspx?scid=kb;en-us;825036

291382 - Frequently asked questions about Windows 2000 DNS and Windows
Server 2003 DNS
http://support.microsoft.com/default.aspx?scid=kb;en-us;291382

296379 - How to Disable NetBIOS on an Incoming Remote Access Interface
[Registry Entry]:
http://support.microsoft.com/?id=296379

_________________________
+++++++++++++++++++++++++++++++++++++++++++++++++++++++

Ace
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top