"Repairing USN Journal record segment"

  • Thread starter Robert Carnegie: Fnord: cc talk-origins@moderators
  • Start date

Robert Carnegie: Fnord: cc talk-origins@moderators

My XP Home is showing
"Repairing USN Journal record segment" on drive C when CHKDSK is run.
But CHKDSK /F won't run on the system volume while Windows is running
normally, and in safe mode or during boot (triggered either by CHKDSK /
F or FSUTIL DIRTY SET) there is no such error detected.

So do I actually have a problem?

What I think I know:

The PC is a Gigabyte M912 notebook with touchscreen.

The "USN Journal" exists because some software on my PC wants it to
exist, that is either not part of Windows or not normally switched on.

It either tracks or replaces normal disk activity.

I could use FSUTIL to delete the USN Journal, but that may be unwise
if something wants to use it.

What I've done that may have caused this condition:

Installed and used F-Secure Internet Security suite. Anti-virus and
such. (Their web site doesn't seem to have heard of USN Journal.)

Used MyDefrag to unfragment the volume. It seemed happy at the time,
and it claims to use the Windows API to perform defragmentation.

This is maybe the biggie: used Linux, Knoppix 6.0.1, to back up the C
partition and partition information, and used SystemRescueCD to resize
C to use less disk space. But that's when I noticed the issue - after
a few reboots and CHKDSK runs - and then I used Knoppix to restore the
backup partition information and the backup copy of C. So now I
should be where I was before this paragraph, if those outside-Windows
tools work as advertised.

Which would imply that I had the problem before I did that part: maybe
I did?

John John - MVP

If you cannot schedule a boot time disk check run the following commands
at a command prompt, pressing <Enter> after each:

chkntfs /d
chkdsk /f


Robert Carnegie: Fnord: cc talk-origins@moderators

John said:
If you cannot schedule a boot time disk check run the following commands
at a command prompt, pressing <Enter> after each:

chkntfs /d
chkdsk /f


I'm guessing I can skip the first part because CHKNTFS C: and CHKDSK /
F do let me schedule the boot disk check and run it. And then it
comes up clean. But if I run it again inside Windows -

Oh, development. The error appears to have changed a couple of times,
and then just gone away?? I thought I did this already and it stayed.

One time it said "Correcting errors in the Volume Bitmap."

Then, next time, error reports like "Deleting index entry
avh_fsav_900_bin in index $I30 of file 16316."

That sounds like my security program, F-Secure Antivirus. I wonder,
is it that doing this!

And now it isn't!

Proslem solved, maybe??

Now, I intend the partition sizes to be:

C: NTFS system, resized to 16 gigabytes
D: and E: FAT32 for Windows page file, more confident Linux access,
space for backup of the whole of C

(There is currently an 80 gigabytes partition D, and a machine
maintenance partition which apparently contains its own Linux)

For instance a 10 gigabytes D might contain an arbitrarily sized 4
gigabytes page file - well, that's the maximum size in FAT32 - and a
compressed image of C, which however I'll probably move to DVD after
creating it.

I estimated that the disk is priced around $1 per gigabyte, so I'd be
spending $10 on page file space and system volume backup space plus
never-have-to-think-about-it-again-for-lifetime-of-machine. Worth the

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question