Reference .NET 2.0 assemblies in 1.1 code?


G

Guest

Hello,

Is there any forward compatability between 1.1 and 2.0? A handful of
assemblies I use in my 1.1 web app were just upgraded to 2.0, and I'm
required to use the new assemblies.

Is this possible without converting my code to 2.0 (or allowing IIS to
handle the 1.1 app as a 2.0 app)? If so, what config changes need to be made?

Thank you,

Eric
 
Ad

Advertisements

M

Mark

2.0 Assemblies will require the 2.0 Framework to run. Running a 2.0 assembly in 1.1 environment will not work as far as I know.

You could install both versions, and then making references to 1.1 assemblies will work from 2.0 projects, but not referencing 2.0 assemblies in a 1.1 project.
 
Ad

Advertisements

G

Guest

Eric,

if you just want to call functionality implemented in .net 2.0 from .net
1.1, you could expose the .net 2.0 functionality as COM and make calls
against that.

Of course, just "calling"... no inheritance, and quite some limitations.

Regards,
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top