Red X on Network Shares


Steve Schwab

I have Vista Ultimate on a SBS 2003 network. I have several network shares
mapped to the Vista machine. When I start a program from "start as
administrator", and then try to access the network shares through the
program, they are shown with a red x in the icon. I can click on them and
they expand properly. The red x then disappears until I reboot. This problem
only shows up when I run a program as administrator. I am logged on as an
administrator. Several of the shares are on the SBS 2003 server but one is a
NAS. All the shares exhibit the same behavior.
The shares work fine when accessing them in normal mode. I have Quickbooks
which must run as administrator and the autobackup function doesn't run
unless I access the mapped drive manually before I run the backup.
Any thoughts?


I have the exact same problem. I am trying to ignore it... I just
hate seeing red x's and I have shortcuts to all my mapped drives on my
quick launch bar so they are really starting to bother me. Some times
it will be just one or two of them but today it is all of them. I
doubt there is a fix for this as I assume it is an icon issue since if
I open up My Computer none of the mapped drives have x's (although
some days they do).

Isn't it funny how the stupidest little things that have no functional
impact can bother us the most?


Steve Schwab

Unfortunately, for me it does have an impact. Programs that are started "as
administrator" can not access those shares automatically unless I go in
manually and open them from with the program. This problem occurs in all
programs that you launched "as administrator" in Vista. For instance, if I
launch notepad "as administrator" the shares will show as disconnected.

If I start command prompt "as administrator" and look at net use, these
shares are shown as disconnected.

It very frustrating but I can't seem to get any help on the problem. I've
googled everything with no good answers. As I've said, I have tried manually
setting up the shares with "net use" to no avail. I'm suspect it's a problem
regarding the two security tokens one gets as an administrator in Vista but
I've not cracked it yet. Any help would be appreciated.

Steve Schwab

I found the answer on a technet forum. Basically, it is a problem with the
"split token" Vista uses for an administrator account. What you need to do
is create a logon script and use the "net use" command to map your drives.
These are created using the "real" administrator priviledges so you should
have access to the shares run running "as administrator". It worked for me.

Here's the procedure to create the logon script.

1. Click Start, type gpedit.msc in the Start Search box and press Enter.

2. In the Group Policy Object Editor, Expand User Configuration > Windows
Settings > Scripts (Logon/Logoff), and double-click Logon in the right pane.

3. In the Logon Properties window, click Add, click Browse.

4. Right-click the space in the \Logon, select New and Text Document.

5. Right-click the new Text Document, select Edit, and type the net use
command to map the network drive (for example, net use Z:

6. Save the file, and rename this .txt file to .bat file (please make
sure that the extension of the file is displayed so that we can convert the
..txt file to .bat file)

7. Click OK to add the .bat file to logon script.

8. After that, please logoff and logon to check if the network drives are
available for the program (run as administrator). If the issue persist,
please launch cmd with elevated token and type net use to confirm if the
Status of the network drives is OK.


That is *really* potentially very useful (as well as interesting).... in
admin account run Cmd and net use... *most* mapped drives "available; "Run
as Administrator" *all* are unavailable!

Does this work in Vista Home Premium - I can't find any gpedit...

Could I achieve the same result by a batch file of net use commands run with
Admin permission via the Task Scheduler on say, Logon, as trigger?


PS Whatever this "split token" stuff means somehow it doesn't seem to be the
sort of thing I should have to know just to get accurate "status" icons!

Steve Schwab

I don't have a copy of Home Premium but I understand that logon scripts are
not supported. You should be able to create the batch file as you describe.
Here's a link that describes how to get the batch file to "run as
administrator". If you put it in your startup folder, you'll have to click
on the UAC prompt everytime you start your computer.

There must be a better way...


I thought HP would be light... thanks for the general confirmation.

Thanks for the link, but scheduling the task and assigning rights when the
task is created avoids *any* UAC prompts at run time... you can do quite a
lot this way... depends how creative you get with the triggers!



Hmmm... any further advice? I was trying it out and got some odd results...

I just "unmapped" a device Computer... Tools.. Disconnect network drive...
Ran cmd as Admin, did net use L: \\server\share and got error 85 "in use"...
So, I tried net use L: /delete - "deleted sucessfully" and then tried to
remap again... success this time.


a) how does one "unmap" as opposed to "disconnect" from the UI?? (Can't find
anything in "Help & support" (sic))
b) if I do remap from my batch file, could I not do something with the
persistence from the command line - then it only needs to be run once and I
don't need to set up a task...

Would appreciate your input -


Steve Schwab

Sorry but I don't think I can be of much further help. I too had the issues
with "in use". It seemed like the issue went away if I waited a bit. Once I
got the script the way I wanted it, it worked fine and I never looked back.
Now my main vista machine is down with a hardware failure and I'm waiting for
new parts to be delivered.


Thanks for the reply Steve... hope the main machine gets better soon :)

I also started another thread "Split Tokens? - Network Shares - red X's,
map/unmap" which led to a pointer to a hotfix which, as it turns out, didn't
fix much

So I guess this one get's filed under "something to look at on a rainy day"
for now...

I'll get back if it rains...

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question