Realtek onboard LAN doesn't work above 10 Mbps


Y

Yousuf Khan

Issue affects Windows 7, Windows XP, and Ubuntu Linux.

As of yesterday, my onboard Realtek Gigabit Ethernet NIC stopped working
fully. It's a "Realtek PCIe GBE Family Controller", model RTL8167. It
was the NIC built into the motherboard of my PC, which is an ASUS
M4A785-M. Initially, it wasn't working at all when plugged into my
router, so I plugged it into a separate hub, and it somehow got working
at the lowest possible speed of 10 Mbps. This NIC has previously worked
both at 100 Mbps, and 1 Gbps!

I also tried this under Ubuntu Linux, thinking maybe it's a Windows
driver problem, but the same problem occurs under Linux, so it's looking
like a real hardware problem. Perhaps it's an autodetect issue, is there
some way to hard-code it to run at 100 Mbps or 1 Gbps, without going
through autodetection?

Yousuf Khan
 
Ad

Advertisements

J

Joe Morris

Yousuf Khan said:
Issue affects Windows 7, Windows XP, and Ubuntu Linux.

As of yesterday, my onboard Realtek Gigabit Ethernet NIC stopped working
fully. It's a "Realtek PCIe GBE Family Controller", model RTL8167. It
was the NIC built into the motherboard of my PC, which is an ASUS
M4A785-M. Initially, it wasn't working at all when plugged into my
router, so I plugged it into a separate hub, and it somehow got working
at the lowest possible speed of 10 Mbps. This NIC has previously worked
both at 100 Mbps, and 1 Gbps!

I also tried this under Ubuntu Linux, thinking maybe it's a Windows
driver problem, but the same problem occurs under Linux, so it's looking
like a real hardware problem. Perhaps it's an autodetect issue, is there
some way to hard-code it to run at 100 Mbps or 1 Gbps, without going
through autodetection?

Assuming that the NIC hasn't experienced a hardware failure, try using a
different cable. Bad network cables (open/short/noisy/whatever) can cause
all sorts of "interesting" symptoms. For the same reason, examine the
sockets on both the NIC and the router for damage.

Joe Morris
 
D

daytripper

Issue affects Windows 7, Windows XP, and Ubuntu Linux.

As of yesterday, my onboard Realtek Gigabit Ethernet NIC stopped working
fully. It's a "Realtek PCIe GBE Family Controller", model RTL8167. It
was the NIC built into the motherboard of my PC, which is an ASUS
M4A785-M. Initially, it wasn't working at all when plugged into my
router, so I plugged it into a separate hub, and it somehow got working
at the lowest possible speed of 10 Mbps. This NIC has previously worked
both at 100 Mbps, and 1 Gbps!

I also tried this under Ubuntu Linux, thinking maybe it's a Windows
driver problem, but the same problem occurs under Linux, so it's looking
like a real hardware problem. Perhaps it's an autodetect issue, is there
some way to hard-code it to run at 100 Mbps or 1 Gbps, without going
through autodetection?

Yousuf Khan

Under Windows Device Manager you can find adapter-specific settings that may
include the ability to force a specific speed. It won't fix a hardware problem
but it might be useful in diagnosis.

As for your specific problem, presuming you've eliminated the network cable
and any other external influences such that the problem is at or behind the IO
panel connector for the nic, one common failure mode - and frankly about the
only one a user has much chance of fixing in the field - is a solder joint
gone bad, which can often be diagnosed by gently flexing the connector body
while the nic is cabled to a working 100Mbit or Gbit port, and checking to see
if the status LEDs change state...

/daytripper
 
Y

Yousuf Khan

Assuming that the NIC hasn't experienced a hardware failure, try using a
different cable. Bad network cables (open/short/noisy/whatever) can cause
all sorts of "interesting" symptoms. For the same reason, examine the
sockets on both the NIC and the router for damage.

Already tried that. Tried about 3 different cables lying around here.

Yousuf Khan
 
K

Kai Harrekilde-Petersen

Yousuf Khan said:
Issue affects Windows 7, Windows XP, and Ubuntu Linux.

As of yesterday, my onboard Realtek Gigabit Ethernet NIC stopped working
fully. It's a "Realtek PCIe GBE Family Controller", model RTL8167. It
was the NIC built into the motherboard of my PC, which is an ASUS
M4A785-M. Initially, it wasn't working at all when plugged into my
router, so I plugged it into a separate hub, and it somehow got working
at the lowest possible speed of 10 Mbps. This NIC has previously worked
both at 100 Mbps, and 1 Gbps!

Sounds like going into a fall-back mode. Have you tried a third
switch/router? - or just connecting it directly to another computer?
You might not get an IP address, but the auto-negotiation should still
work and give you a link speed/mode.
Perhaps it's an autodetect issue, is there
some way to hard-code it to run at 100 Mbps or 1 Gbps, without going
through autodetection?

Yes, through the PHY. But in that case you MUST disable auto-negotiation
at both ends of the link (and set them to the same mode).

Good luck,


Kai
 
Ad

Advertisements

Y

Yousuf Khan

Sounds like going into a fall-back mode. Have you tried a third
switch/router? - or just connecting it directly to another computer?
You might not get an IP address, but the auto-negotiation should still
work and give you a link speed/mode.

Well, I did try connecting the interface directly into the broadband
modem, bypassing the routers, switches, etc. It wouldn't work there
either with autonegotiate on.

However, a strange development happened last night. I bought a new
gigabit network card for the machine, and got it working, moved the
cable from the onboard NIC to the add-in NIC, etc. Everything was
working like normal with the new NIC. Then a couple of hours later, I
tried the onboard NIC again, by plugging a second cable into it, and
strangely enough it worked again! I'm not saying that the addition of
the add-in NIC caused the onboard NIC to work again, it's just a
coincidence. Perhaps it required a few hours of "rest"? In fact, both
NICs were working simultaneously at gigabit speeds! Gremlins in the system.
Yes, through the PHY. But in that case you MUST disable auto-negotiation
at both ends of the link (and set them to the same mode).

Good luck,

Ah, okay that might explain why non-autonegotiate never worked, as I
didn't hard code it into the switcher end too. I just changed it at the
computer end, that's all.

Yousuf Khan
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top