I have just prchased a sandisk cruzer mini 2Gb and hoped to use it with
readyboost. However i am getting an error stating 'The device is plugged into
an unsuppoerted interface'
It is definately a USB2.0 port.
Can anyone offer any advice please?

Times2 Innovations

i have usb 2.0 as well, but when vista installed it kicked it back to 1.5
I use an external drive for temp files and wanted to do the same thing.
Whenever i turn the drive on now it says I should upgrade to usb 2.0 to make
readyboost work properly.

I tried installing the drivers for my board "that worked in XP" but it won't
allow the install saying wrong windows version.
lol, guess I am screwed for my usb now.

dual processor 1.8 athlons with 4 gig ram - geforce 5700 with 256 megs ram -
Highpoint raid with 7 hard drives and one dvd burner


I have 4 onboard USB ports and a PCI hub with an extra 4. I have tried all
eight, each one with the same message about the interface being unsupported!

Lang Murphy

Hmmm... don't really have an answer for you... I've got 4 PC's running
Vista, each with USB 2.0 and I've never seen that error msg when either
plugging in a thumb drive or an external hard drive or using a thumb drive
for ReadyBoost. Know that's not much help... not sure what to tell ya other
than it works here.


John Barnes

I basically have the same setup, and mine got the same message from the PCI
card, but works fine from the motherboard USB, so I have no suggestions.
Good luck.


I had the same issue with a SanDisk Cruszer 2GB; it will not work. I have a
Sony Micro Vault that work like a champ. On my last visit to Micro Center I
picked up a $15 no-name 1GB drive that also works.

I think it has something to do with the internal memory controller in the
drive; if performance isn’t fast enough Vista won’t use it.


I had the same problem with a SanDisk Crusier 512MB, it kept saying that it
was not plugged into a USB 2.0 port, even though I knew that the port was USB
2.0. I formatted the drive to FAT32 (making sure I had got all my info off
:) and that fixed the problem.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question