problems with reconnecting mapped network drive


D

dpoole

Hi,

I have following environment at home:
- 1 Thecus NAS (Samba)
- 1 Vista Ultimate machine
- 1 Windows XP machince

All of them are members of one workgroup.

I connect sucessfully the network drives on the NAS with standard "net
use" behavoir from both windows machines. The credentials for the
authentification are different as the log-in user credentials from the
windows machines.

- now my problem -
On the Vista machine after a reboot the network drives to the NAS can
´t be automaticly reconnected, although
I marked the function "automatic restore" by mapping the drive.

On the XP machine the automatic reconnect to the network drives work
without any problems.

I compared the settings for the mapped network drives in the registry
between the vista and the xp machine.
All the same!

I´ve tryed to change the authentication method on the vista machine as
described here http://www.jimmah.com/vista/Networking/ntlm.aspx. But
the problem is still there!

- my workaround was -
I built a autostart cmd-script with a couple of net use commands to
map the network drives. I run the script
with administrator permissions, because with standard user rights it
doesn´t work. But a started application (like Media Center) with
normal standard user permissions can´t reach the prior mapped drives.
Damn!

I get frustration!
Any suggestions for my problem !?
 
Ad

Advertisements

M

Michael A. Bishop \(MSFT\)

It's worth pointing out that Samba is implementing a reverse-engineered
Windows-compatible client and server, not the other way around. However,
that's a side-topic.

Vista, by default, authenticates using the more secure NTLMv2. This has
been used in Windows since NT4, but was only added to Samba in 3.0.22.
Contact Buffalo for an update to the Samba in your NAS box.

If they don't have an update available, you can also relax the security
requirements on Vista. Open secpol.msc, go to Local Policy\Security
Options\Network security: LAN Manager authentication level, and change it
to "Send LM & NTLM - use NTLMv2 session security if negotiated." (For Home
SKUs that don't have secpol.msc, open regedit and change
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\LMCompatibilityLevel
from 0x3 to 0x1.)

"Scott Mollica" a écrit dans le message de
news:[email protected]
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top